summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-05-23 09:31:04 -0400
committerBrian Evans <grknight@gentoo.org>2016-05-23 09:31:04 -0400
commite6087c1d9868490765053cf56142c4cb52ce038b (patch)
treef9873e557309bdfce48eb0aa93d39621b74e2560 /net-libs/rabbitmq-c/rabbitmq-c-0.8.0.ebuild
parentprofiles/arch/alpha: Mask luajit USE flag (diff)
downloadgentoo-e6087c1d9868490765053cf56142c4cb52ce038b.tar.gz
gentoo-e6087c1d9868490765053cf56142c4cb52ce038b.tar.bz2
gentoo-e6087c1d9868490765053cf56142c4cb52ce038b.zip
net-libs/rabbitmq-c: Version bump wrt bug 545250
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'net-libs/rabbitmq-c/rabbitmq-c-0.8.0.ebuild')
-rw-r--r--net-libs/rabbitmq-c/rabbitmq-c-0.8.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-libs/rabbitmq-c/rabbitmq-c-0.8.0.ebuild b/net-libs/rabbitmq-c/rabbitmq-c-0.8.0.ebuild
new file mode 100644
index 000000000000..82dfd210115e
--- /dev/null
+++ b/net-libs/rabbitmq-c/rabbitmq-c-0.8.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit cmake-utils
+
+DESCRIPTION="RabbitMQ C client"
+HOMEPAGE="https://github.com/alanxz/rabbitmq-c"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/alanxz/rabbitmq-c.git"
+else
+ SRC_URI="https://github.com/alanxz/rabbitmq-c/archive/v${PV}.zip -> ${PN}-v${PV}.zip"
+ KEYWORDS="~amd64 ~arm ~hppa ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/4"
+IUSE="doc libressl test +ssl static-libs tools"
+
+REQUIRED_USE="test? ( static-libs )"
+
+RDEPEND="ssl? (
+ libressl? ( dev-libs/libressl:= )
+ !libressl? ( dev-libs/openssl:0= )
+ )
+ tools? ( dev-libs/popt )"
+DEPEND="${DEPEND}
+ doc? ( app-doc/doxygen )
+ tools? ( app-text/xmlto )"
+DOCS=( AUTHORS README.md THANKS TODO )
+
+src_configure() {
+ mycmakeargs=(
+ -DCMAKE_SKIP_RPATH=ON
+ -DBUILD_API_DOCS=$(usex doc)
+ -DBUILD_STATIC_LIBS=$(usex static-libs)
+ -DBUILD_TESTS=$(usex test)
+ -DBUILD_TOOLS=$(usex tools)
+ -DBUILD_TOOLS_DOCS=$(usex tools)
+ -DENABLE_SSL_SUPPORT=$(usex ssl)
+ )
+ cmake-utils_src_configure
+}