summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-12-26 16:14:28 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-12-26 16:14:28 +0100
commitd77087bbc1076b2c3aab19e4649e6c6fbacb6d9b (patch)
treed1503e3f1498e8dd440ccce5a82546477fa897dd /net-libs/rabbitmq-c
parentsys-block/storcli: missing DEPEND="app-arch/unzip" (diff)
downloadgentoo-d77087bbc1076b2c3aab19e4649e6c6fbacb6d9b.tar.gz
gentoo-d77087bbc1076b2c3aab19e4649e6c6fbacb6d9b.tar.bz2
gentoo-d77087bbc1076b2c3aab19e4649e6c6fbacb6d9b.zip
net-libs/rabbitmq-c: security cleanup
Bug: https://bugs.gentoo.org/701810 Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-libs/rabbitmq-c')
-rw-r--r--net-libs/rabbitmq-c/Manifest1
-rw-r--r--net-libs/rabbitmq-c/rabbitmq-c-0.9.0.ebuild55
2 files changed, 0 insertions, 56 deletions
diff --git a/net-libs/rabbitmq-c/Manifest b/net-libs/rabbitmq-c/Manifest
index 21200c4aaa25..f78f85b7a967 100644
--- a/net-libs/rabbitmq-c/Manifest
+++ b/net-libs/rabbitmq-c/Manifest
@@ -1,2 +1 @@
DIST rabbitmq-c-0.10.0.tar.gz 145361 BLAKE2B 99b53d5178fa407225d2060584239af83377027fb6a209002d11ed54be4b49bab70ae55c86ab971394ab745a632ece6f070f9c10a9bdd330de4778edbd8e1ea8 SHA512 52a1194fab2dc8698ed065d63898e32aa004a4d68080d4aaf5cb7148cc28ad967283f7a99910d7f054cbba92b487b3a67b839b6f0bd88486ef9be043c9517d4c
-DIST rabbitmq-c-v0.9.0.zip 227245 BLAKE2B ea37e0a9734bc7a8923cab880a9e150f055bab83bb79eb793882a1d435e6e435fbf4610034235f858d0e4d20978287b9432b312c8c3eea5e588655dc2f831554 SHA512 0cac0e26b4caca3de22b468200a20c38c8ace1a824442faa0855d93922b0c3a649fc2067366f6694eca0be635187ca9a9cfe47643472f4abb3d67028768f49fb
diff --git a/net-libs/rabbitmq-c/rabbitmq-c-0.9.0.ebuild b/net-libs/rabbitmq-c/rabbitmq-c-0.9.0.ebuild
deleted file mode 100644
index 6969404a06ed..000000000000
--- a/net-libs/rabbitmq-c/rabbitmq-c-0.9.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit cmake-utils
-
-DESCRIPTION="RabbitMQ C client"
-HOMEPAGE="https://github.com/alanxz/rabbitmq-c"
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/alanxz/${PN}.git"
-else
- SRC_URI="https://github.com/alanxz/${PN}/archive/v${PV}.zip -> ${PN}-v${PV}.zip"
- KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ppc ppc64 ~s390 sparc x86"
-fi
-
-LICENSE="MIT"
-SLOT="0/4"
-IUSE="doc libressl test +ssl static-libs tools"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="test? ( static-libs )"
-
-RDEPEND="ssl? (
- libressl? ( dev-libs/libressl:= )
- !libressl? ( dev-libs/openssl:0= )
- )
- tools? ( dev-libs/popt )"
-DEPEND="${DEPEND}
- doc? ( app-doc/doxygen )
- tools? ( app-text/xmlto )"
-DOCS=( AUTHORS README.md THANKS TODO )
-
-src_configure() {
- mycmakeargs=(
- -DCMAKE_SKIP_RPATH=ON
- -DBUILD_API_DOCS=$(usex doc)
- -DBUILD_STATIC_LIBS=$(usex static-libs)
- -DBUILD_TESTS=$(usex test)
- -DBUILD_TOOLS=$(usex tools)
- -DBUILD_TOOLS_DOCS=$(usex tools)
- -DENABLE_SSL_SUPPORT=$(usex ssl)
- )
- cmake-utils_src_configure
-}
-
-src_test() {
- pushd "${BUILD_DIR}" > /dev/null || die
-
- # Skip "basic" test which requires running local rabbitmq-server instance,
- # see https://github.com/alanxz/rabbitmq-c/issues/530
- ctest -v -E basic || die
-}