summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-05-28 17:27:09 +0200
committerPacho Ramos <pacho@gentoo.org>2016-05-28 17:49:18 +0200
commit9c5dcad2498ae69b3ccf72274aef29626936423c (patch)
treeb67594ad5ad7e9d130458622f8fd24b6a28d5077 /net-libs/rest
parentdev-util/meld: Version bump (diff)
downloadgentoo-9c5dcad2498ae69b3ccf72274aef29626936423c.tar.gz
gentoo-9c5dcad2498ae69b3ccf72274aef29626936423c.tar.bz2
gentoo-9c5dcad2498ae69b3ccf72274aef29626936423c.zip
net-libs/rest: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'net-libs/rest')
-rw-r--r--net-libs/rest/Manifest1
-rw-r--r--net-libs/rest/rest-0.8.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/net-libs/rest/Manifest b/net-libs/rest/Manifest
index ae8137ad18d9..59dcd200ed3e 100644
--- a/net-libs/rest/Manifest
+++ b/net-libs/rest/Manifest
@@ -1 +1,2 @@
DIST rest-0.7.93.tar.xz 321072 SHA256 c710644455340a44ddc005c645c466f05c0d779993138ea21a62c6082108b216 SHA512 50afb6730b8065d418e724c8afdb903521582669fb8744d91f400ebdbdb52323117193d3039ef4320b1bf7e3f60cc19ee6826ff7cb6c9bd680fc1ced067dff3b WHIRLPOOL 0cee91748750d7afc4a1108a8db91529400bdfb79fac122e11e631b96e9b694fb4bac8f0ca1554e221b9eff9268f4bea2d5802d199c3e69e0c9890d877e775cf
+DIST rest-0.8.0.tar.xz 334024 SHA256 e7b89b200c1417073aef739e8a27ff2ab578056c27796ec74f5886a5e0dff647 SHA512 dfcfed4196e613ed4415ea04eaa890e47d1d2e6899afdefff3dd7bfed5bcace58724158deb4c0cc7974f9a4493d00d5c0a27415160f2795df81c2210c14a823a WHIRLPOOL b4a2de0fac2fe5bd6280c5e06a18a2b3b2fe1ca3d6f6a38ae1a34c3a9d1a3d8efa8c19ffac15ed4f9ca2ef7a7febf225f8954f6446c3a7078a3e2c02ff08ee73
diff --git a/net-libs/rest/rest-0.8.0.ebuild b/net-libs/rest/rest-0.8.0.ebuild
new file mode 100644
index 000000000000..0d5501d7d4fc
--- /dev/null
+++ b/net-libs/rest/rest-0.8.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 multilib-minimal virtualx
+
+DESCRIPTION="Helper library for RESTful services"
+HOMEPAGE="https://wiki.gnome.org/Projects/Librest"
+
+LICENSE="LGPL-2.1"
+SLOT="0.7"
+IUSE="+introspection test"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# Coverage testing should not be enabled
+RDEPEND="
+ app-misc/ca-certificates
+ >=dev-libs/glib-2.24:2[${MULTILIB_USEDEP}]
+ dev-libs/libxml2:2[${MULTILIB_USEDEP}]
+ net-libs/libsoup:2.4[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.13
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ test? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
+"
+
+multilib_src_configure() {
+ # gnome support only adds dependency on obsolete libsoup-gnome
+ # https://bugzilla.gnome.org/show_bug.cgi?id=758166
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ --disable-static \
+ --disable-gcov \
+ --without-gnome \
+ --with-ca-certificates="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt \
+ $(multilib_native_use_enable introspection)
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/reference/rest/html docs/reference/rest/html || die
+ fi
+}
+
+multilib_src_test() {
+ # Tests need dbus
+ Xemake check
+}
+
+multilib_src_compile() {
+ gnome2_src_compile
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}