summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-03-24 07:07:46 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-03-24 07:07:46 +0000
commit2687387ee6466a9bca0ec983a72d5ab4bcddfc61 (patch)
tree97df0413e8382c27a0d626c0e3582fde5a4047f7 /net-libs/rpcsvc-proto
parentapp-misc/golly: drop old (diff)
downloadgentoo-2687387ee6466a9bca0ec983a72d5ab4bcddfc61.tar.gz
gentoo-2687387ee6466a9bca0ec983a72d5ab4bcddfc61.tar.bz2
gentoo-2687387ee6466a9bca0ec983a72d5ab4bcddfc61.zip
net-libs/rpcsvc-proto: revert "drop old"
This reverts commit 0fce167fe7807642cf1249861be0b711506e80d6. Dropped latest ebuild by accident. Reported-by: Mr_Bones_ Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'net-libs/rpcsvc-proto')
-rw-r--r--net-libs/rpcsvc-proto/rpcsvc-proto-1.4-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/rpcsvc-proto/rpcsvc-proto-1.4-r1.ebuild b/net-libs/rpcsvc-proto/rpcsvc-proto-1.4-r1.ebuild
new file mode 100644
index 000000000000..bea100de5348
--- /dev/null
+++ b/net-libs/rpcsvc-proto/rpcsvc-proto-1.4-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="rpcsvc protocol definitions from glibc"
+HOMEPAGE="https://github.com/thkukuk/rpcsvc-proto"
+SRC_URI="https://github.com/thkukuk/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1+ BSD"
+KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~riscv s390 ~sh sparc x86"
+IUSE=""
+
+# sys-devel/gettext is only for libintl detection macros.
+DEPEND="sys-devel/gettext"
+RDEPEND="
+ !<sys-libs/glibc-2.26
+ virtual/libintl
+"
+
+PATCHES=("${FILESDIR}"/${P}-external-libintl.patch)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ # provided by sys-fs/quota[rpc]
+ rm "${ED}"/usr/include/rpcsvc/rquota.{x,h} || die
+}