summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorfrace <frace@users.noreply.github.com>2017-01-10 20:31:01 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-23 22:19:22 +0100
commite7b104c04e9cf231ccbff86dd3375a50244f7184 (patch)
treecdd6b1667084e14098297a86aa15a6d58a9f1e2a /net-libs/shairplay/shairplay-0_pre20170118.ebuild
parentsys-devel/gdb: version bump to 7.12.1 (diff)
downloadgentoo-e7b104c04e9cf231ccbff86dd3375a50244f7184.tar.gz
gentoo-e7b104c04e9cf231ccbff86dd3375a50244f7184.tar.bz2
gentoo-e7b104c04e9cf231ccbff86dd3375a50244f7184.zip
net-libs/shairplay: New package needed by media-tv/kodi
Gentoo-bug: 538932, 468558, 458734 Reported-by: hal Closes: https://github.com/gentoo/gentoo/pull/3425
Diffstat (limited to 'net-libs/shairplay/shairplay-0_pre20170118.ebuild')
-rw-r--r--net-libs/shairplay/shairplay-0_pre20170118.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-libs/shairplay/shairplay-0_pre20170118.ebuild b/net-libs/shairplay/shairplay-0_pre20170118.ebuild
new file mode 100644
index 000000000000..6c6560a0314e
--- /dev/null
+++ b/net-libs/shairplay/shairplay-0_pre20170118.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools vcs-snapshot
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/juhovh/shairplay.git"
+else
+ EGIT_COMMIT="498bc5bcdd305e04721f94a04b9f26a7da72673f"
+ SRC_URI="https://github.com/juhovh/shairplay/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Apple airplay and raop protocol server"
+HOMEPAGE="https://github.com/juhovh/shairplay"
+LICENSE="BSD LGPL-2.1 MIT"
+
+SLOT="0"
+IUSE="alac static-libs tools"
+
+DEPEND="
+ tools? ( media-libs/libao )
+"
+
+RDEPEND="
+ alac? (
+ media-sound/alac_decoder
+ net-libs/shairplay[tools]
+ )
+ tools? (
+ dev-libs/openssl:0=
+ net-dns/avahi[mdnsresponder-compat]
+ )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}