summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-11-18 14:49:54 -0500
committerCraig Andrews <candrews@gentoo.org>2018-11-18 14:52:27 -0500
commit21648ed8d57e22e1fa605f3ea6d79760c6e12b96 (patch)
treeacc7fc76ef8d0f60ea37fb86ec5c78f31f204e6a /net-libs/shairplay/shairplay-0_pre20180824-r1.ebuild
parentkde-apps/kdecore-meta: Drop 18.08.3 (r0) (diff)
downloadgentoo-21648ed8d57e22e1fa605f3ea6d79760c6e12b96.tar.gz
gentoo-21648ed8d57e22e1fa605f3ea6d79760c6e12b96.tar.bz2
gentoo-21648ed8d57e22e1fa605f3ea6d79760c6e12b96.zip
net-libs/shairplay: fix use flags and dependencies
media-libs/libao is always required net-dns/avahi[mdnsresponder-compat] is a build time dependency Drop alac use flag; media-sound/alac_decoder is never used drop tools use flag as tools are not configurable Closes: https://bugs.gentoo.org/671410 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-libs/shairplay/shairplay-0_pre20180824-r1.ebuild')
-rw-r--r--net-libs/shairplay/shairplay-0_pre20180824-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-libs/shairplay/shairplay-0_pre20180824-r1.ebuild b/net-libs/shairplay/shairplay-0_pre20180824-r1.ebuild
new file mode 100644
index 000000000000..e8573a8c12b6
--- /dev/null
+++ b/net-libs/shairplay/shairplay-0_pre20180824-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/juhovh/${PN}.git"
+else
+ EGIT_COMMIT="096b61ad14c90169f438e690d096e3fcf87e504e"
+ SRC_URI="https://github.com/juhovh/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Apple airplay and raop protocol server"
+HOMEPAGE="https://github.com/juhovh/shairplay"
+LICENSE="BSD LGPL-2.1 MIT
+ playfair? ( GPL-3+ )"
+
+SLOT="0"
+IUSE="+playfair static-libs"
+
+DEPEND="
+ net-dns/avahi[mdnsresponder-compat]
+ media-libs/libao
+"
+
+RDEPEND="
+ ${DEPEND}
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with playfair) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}