summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosiah Mullins <jomull01@protonmail.com>2020-03-25 09:53:36 -0400
committerJoonas Niilola <juippis@gentoo.org>2020-03-28 16:21:12 +0200
commit7b11957c551558ede8f2f03f092e364a7cb33903 (patch)
tree74e00c1423ae52adfc75e0a9b5db5b14cafefc6d /net-libs/tox
parentapp-office/libreoffice-bin-debug: Fix x86 and liborcus problems (diff)
downloadgentoo-7b11957c551558ede8f2f03f092e364a7cb33903.tar.gz
gentoo-7b11957c551558ede8f2f03f092e364a7cb33903.tar.bz2
gentoo-7b11957c551558ede8f2f03f092e364a7cb33903.zip
net-libs/tox: Remove old version 0.2.9-r1
Closes: https://bugs.gentoo.org/689022 Closes: https://bugs.gentoo.org/687580 Closes: https://bugs.gentoo.org/688692 Signed-off-by: Josiah Mullins <JoMull01@protonmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-libs/tox')
-rw-r--r--net-libs/tox/Manifest1
-rw-r--r--net-libs/tox/tox-0.2.9-r1.ebuild111
2 files changed, 0 insertions, 112 deletions
diff --git a/net-libs/tox/Manifest b/net-libs/tox/Manifest
index 64a9543861a6..a8104b5ef544 100644
--- a/net-libs/tox/Manifest
+++ b/net-libs/tox/Manifest
@@ -1,2 +1 @@
DIST c-toxcore-0.2.10.tar.gz 515842 BLAKE2B 8e79f9a5045b5fef7825e5eb21644625607d86e472ec75ff45ff826712efa515682f9439181d52444b2a6a21472c6e78a3bea5bb7e356373faf733e2644a315d SHA512 8a6a78c52a67be0b727d0d3a8d1cece20ad716a2e694df0aa747eee7764f64c957458584f59db5e727a9803ed7b21adc1ad8d7e80fd6651e7774ca3504b38fc7
-DIST c-toxcore-0.2.9.tar.gz 510806 BLAKE2B e67bdb86757d1431cc9d627dbc9afa9f54c3deb7814b38c2126849d10e9225aa58d2b23d175622678be74894ea197d3084719422a605d95eb4c55c4597a79f98 SHA512 917826a906a9ca4f04f34494616b8e36ec9e74c6b0709c50e8fe2dd9da680d170013fef242a3fe1b834e8e54cd2dde6be1c14e5d977f8531436ef34280bc3966
diff --git a/net-libs/tox/tox-0.2.9-r1.ebuild b/net-libs/tox/tox-0.2.9-r1.ebuild
deleted file mode 100644
index a6e9875d9fcb..000000000000
--- a/net-libs/tox/tox-0.2.9-r1.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake systemd
-
-MY_P="c-toxcore-${PV}"
-DESCRIPTION="Encrypted P2P, messaging, and audio/video calling platform"
-HOMEPAGE="https://tox.chat"
-SRC_URI="https://github.com/TokTok/c-toxcore/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0/0.2"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="+av daemon dht-node ipv6 log-debug +log-error log-info log-trace log-warn static-libs test"
-
-REQUIRED_USE="?? ( log-debug log-error log-info log-trace log-warn )
- daemon? ( dht-node )"
-RESTRICT="!test? ( test )"
-
-BDEPEND="virtual/pkgconfig"
-DEPEND=">=dev-libs/libsodium-0.6.1:=[asm,urandom,-minimal]
- av? ( media-libs/libvpx
- media-libs/opus )
- daemon? ( dev-libs/libconfig )"
-RDEPEND="${DEPEND}
- daemon? ( acct-group/tox
- acct-user/tox )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- cmake_src_prepare
- #remove faulty tests
- for testname in bootstrap lan_discovery save_compatibility tcp_relay tox_many_tcp; do
- sed -i -e "/^auto_test(${testname})$/d" CMakeLists.txt || die
- done
-}
-
-src_configure() {
- local mycmakeargs=(
- -DAUTOTEST=$(usex test)
- -DBOOTSTRAP_DAEMON=$(usex daemon)
- -DBUILD_MISC_TESTS=$(usex test)
- -DBUILD_TOXAV=$(usex av)
- -DDHT_BOOTSTRAP=$(usex dht-node)
- -DENABLE_SHARED=ON
- -DENABLE_STATIC=$(usex static-libs)
- -DMUST_BUILD_TOXAV=$(usex av))
- if use test; then
- mycmakeargs+=(
- -DBUILD_AV_TEST=$(usex av)
- -DTEST_TIMEOUT_SECONDS=120
- -DUSE_IPV6=$(usex ipv6))
- else
- mycmakeargs+=(
- -DBUILD_AV_TEST=OFF
- -DUSE_IPV6=OFF)
- fi
-
- if use log-trace; then
- mycmakeargs+=(-DMIN_LOGGER_LEVEL="TRACE")
- elif use log-debug; then
- mycmakeargs+=(-DMIN_LOGGER_LEVEL="DEBUG")
- elif use log-info; then
- mycmakeargs+=(-DMIN_LOGGER_LEVEL="INFO")
- elif use log-warn; then
- mycmakeargs+=(-DMIN_LOGGER_LEVEL="WARNING")
- elif use log-error; then
- mycmakeargs+=(-DMIN_LOGGER_LEVEL="ERROR")
- else
- mycmakeargs+=(-DMIN_LOGGER_LEVEL="")
- einfo "Logging disabled"
- fi
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- if use daemon; then
- newinitd "${FILESDIR}"/initd tox-dht-daemon
- newconfd "${FILESDIR}"/confd tox-dht-daemon
- insinto /etc
- doins "${FILESDIR}"/tox-bootstrapd.conf
- systemd_dounit "${FILESDIR}"/tox-bootstrapd.service
- fi
-}
-
-pkg_postinst() {
- if use dht-node; then
- ewarn "There is currently an unresolved issue with tox"
- ewarn "DHT Bootstrap node that causes the program to be"
- ewarn "built with a null library reference. This"
- ewarn "causes an infinite loop for certain revdep-rebuild"
- ewarn "commands. If you aren't running a node, please"
- ewarn "consider disabling the DHT-node use flag."
- fi
- if use daemon; then
- if [[ -f ${EROOT}/var/lib/tox-dht-bootstrap/key ]]; then
- ewarn "Backwards compatability with the bootstrap daemon might have been"
- ewarn "broken a while ago. To resolve this issue, REMOVE the following files:"
- ewarn " ${EROOT}/var/lib/tox-dht-bootstrap/key"
- ewarn " ${EROOT}/etc/tox-bootstrapd.conf"
- ewarn " ${EROOT}/run/tox-dht-bootstrap/tox-dht-bootstrap.pid"
- ewarn "Then just re-emerge net-libs/tox"
- fi
- fi
-}