summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2022-03-15 14:27:27 +0200
committerIonen Wolkens <ionen@gentoo.org>2022-03-15 16:03:15 -0400
commit49cc14c0f4f76a995d4764369523887320ebfa8c (patch)
tree3c3136a312cd359cf27812a5c3df9cb86a25cf9a /net-libs/toxext
parentdev-util/maturin: add 0.12.11 (diff)
downloadgentoo-49cc14c0f4f76a995d4764369523887320ebfa8c.tar.gz
gentoo-49cc14c0f4f76a995d4764369523887320ebfa8c.tar.bz2
gentoo-49cc14c0f4f76a995d4764369523887320ebfa8c.zip
net-libs/toxext: append-flags -fPIC to fix build with CLANG and LLD
Closes: https://bugs.gentoo.org/831338 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-libs/toxext')
-rw-r--r--net-libs/toxext/toxext-0.0.3.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/net-libs/toxext/toxext-0.0.3.ebuild b/net-libs/toxext/toxext-0.0.3.ebuild
index 83c395524343..4e41feba68bf 100644
--- a/net-libs/toxext/toxext-0.0.3.ebuild
+++ b/net-libs/toxext/toxext-0.0.3.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Extension Library for Tox"
HOMEPAGE="https://github.com/toxext/toxext"
@@ -22,4 +22,8 @@ src_prepare() {
sed -i 's/-Werror//' CMakeLists.txt || die
sed -i '/-fsanitize=/d' test/CMakeLists.txt || die
+
+ # Fix build with CLANG and LLD.
+ # https://bugs.gentoo.org/831338
+ append-flags -fPIC
}