summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-05-15 05:50:17 +0200
committerJeroen Roovers <jer@gentoo.org>2020-05-15 05:50:34 +0200
commit376dffcf0aca0ed839bb5cf40fdd44ba71b8cd1a (patch)
tree070b38db3f611c7b80d4ff4fc96d69d5e64488b5 /net-libs/wandio
parentprofiles/package.mask: mask zfs-0.7.x and co (diff)
downloadgentoo-376dffcf0aca0ed839bb5cf40fdd44ba71b8cd1a.tar.gz
gentoo-376dffcf0aca0ed839bb5cf40fdd44ba71b8cd1a.tar.bz2
gentoo-376dffcf0aca0ed839bb5cf40fdd44ba71b8cd1a.zip
net-libs/wandio: Version 4.2.3_p1
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-libs/wandio')
-rw-r--r--net-libs/wandio/Manifest1
-rw-r--r--net-libs/wandio/wandio-4.2.3_p1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-libs/wandio/Manifest b/net-libs/wandio/Manifest
index bf507fb508a7..591abedd52b5 100644
--- a/net-libs/wandio/Manifest
+++ b/net-libs/wandio/Manifest
@@ -3,3 +3,4 @@ DIST wandio-4.0.0.tar.gz 385706 BLAKE2B 7f6e7855a06ae2c23138598c5cf16c9a38f57932
DIST wandio-4.1.2.tar.gz 409755 BLAKE2B 90bf4cf9bdd6cdd87668614c91bbd5fd8dc7c526a8e985737d1dced760209be205052221ebfe9ebf92b7c05492298da275498aee1e3817d73235488da9ee2cc1 SHA512 0d74aec9fe2faf678d369fec420f56ae78eedc5f38b70b403034fb030a9c0d1d5a54225b111993ce59b79d8e02ad49a2b0ca4697c7910149f2ae54379d9e19c4
DIST wandio-4.2.0.tar.gz 410273 BLAKE2B f133e783f6f47a6d55058684b4965d02816a0fe835bcce274292287492e53007ebfce3b447d6ac9f58d8d4626ba20b7b6a7e5e6ac3cc054ef49d70c843c0216f SHA512 befbca1479b32cca909c6125e54be0a061d1fecfc01d9bca7cbd54f86564d39a02714805c7583d9b50896bb553a197e0f86fd10d4424782f5e9798a0cb440923
DIST wandio-4.2.1.tar.gz 15417543 BLAKE2B 704ed3846cda3755ad305bdb84febed75ba1f044d0380465041cab9f44dc16c1a7fc8bb5a8d4292d5f6c12d6783af45d93bdce70228afc5438bbe7d6f5714491 SHA512 eab9180e477f63e37b11d090b772037fc319554495e6f3656da66e34dcde25f47566e87b71255645d9bb5aaaff721f0dceace4d880cdca491c05a9de6852553b
+DIST wandio-4.2.3_p1.tar.gz 15418423 BLAKE2B 1274f10b87964e2dc87ed25a465991b1e4e9211b75fb5ac5a13a0aa535ff30ddfa69059b3d41de7dc758220bda8dd9d02ca7ed31b7c0ca2997641968cc729e48 SHA512 b4bfff9d33010c04826318c560592ee7f7aba9fccd0eba0f29c6294a636971bf4ac5105ffb9addfc22946e7b7234396dafa6c7e0a0d8de3ee1b7e586c069b438
diff --git a/net-libs/wandio/wandio-4.2.3_p1.ebuild b/net-libs/wandio/wandio-4.2.3_p1.ebuild
new file mode 100644
index 000000000000..5da40030c1d1
--- /dev/null
+++ b/net-libs/wandio/wandio-4.2.3_p1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="C library for simple and efficient file IO"
+HOMEPAGE="https://research.wand.net.nz/software/libwandio.php"
+SRC_URI="https://github.com/wanduow/${PN}/archive/${PV/_p/-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/6"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 http lzma lzo static-libs test zlib"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !<net-libs/libtrace-4
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ lzo? ( dev-libs/lzo )
+ http? ( net-misc/curl )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( app-arch/lzop )
+"
+S=${WORKDIR}/${P/_p/-}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with bzip2) \
+ $(use_with http) \
+ $(use_with lzma) \
+ $(use_with lzo) \
+ $(use_with zlib)
+}
+
+src_test() {
+ pushd test || die
+ sh do-basic-tests.sh
+}