summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-27 03:42:09 +0000
committerSam James <sam@gentoo.org>2021-02-27 04:11:48 +0000
commit71931fba1ed3bd70e5c6ba9b7b30c4e46f34c492 (patch)
tree65434632a98c2d23dd79f7699fd7499c6d63791c /net-libs/wandio
parentnet-libs/wandio: cleanup old (diff)
downloadgentoo-71931fba1ed3bd70e5c6ba9b7b30c4e46f34c492.tar.gz
gentoo-71931fba1ed3bd70e5c6ba9b7b30c4e46f34c492.tar.bz2
gentoo-71931fba1ed3bd70e5c6ba9b7b30c4e46f34c492.zip
net-libs/wandio: port to EAPI 7, fix tests
Closes: https://bugs.gentoo.org/725040 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/wandio')
-rw-r--r--net-libs/wandio/wandio-4.2.3_p1-r1.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/net-libs/wandio/wandio-4.2.3_p1-r1.ebuild b/net-libs/wandio/wandio-4.2.3_p1-r1.ebuild
index e0d614fcb241..4eef4248a4d6 100644
--- a/net-libs/wandio/wandio-4.2.3_p1-r1.ebuild
+++ b/net-libs/wandio/wandio-4.2.3_p1-r1.ebuild
@@ -1,18 +1,21 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit autotools
DESCRIPTION="C library for simple and efficient file IO"
HOMEPAGE="https://research.wand.net.nz/software/libwandio.php"
SRC_URI="https://github.com/wanduow/${PN}/archive/${PV/_p/-}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P/_p/-}"
LICENSE="LGPL-3"
SLOT="0/6"
KEYWORDS="~amd64 ~x86"
-IUSE="bzip2 http lzma lzo static-libs test zlib"
+IUSE="bzip2 http lzma lzo test zlib"
RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( lzma lzo )"
RDEPEND="
!<net-libs/libtrace-4
@@ -26,7 +29,6 @@ DEPEND="
${RDEPEND}
test? ( app-arch/lzop )
"
-S=${WORKDIR}/${P/_p/-}
src_prepare() {
default
@@ -35,7 +37,7 @@ src_prepare() {
src_configure() {
econf \
- $(use_enable static-libs static) \
+ --disable-static \
$(use_with bzip2) \
$(use_with http) \
$(use_with lzma) \
@@ -43,12 +45,12 @@ src_configure() {
$(use_with zlib)
}
+src_test() {
+ pushd test || die
+ ${CONFIG_SHELL}/bin/bash do-basic-tests.sh || die
+}
+
src_install() {
default
find "${ED}" -name '*.la' -delete || die
}
-
-src_test() {
- pushd test || die
- sh do-basic-tests.sh
-}