summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-07-26 21:10:18 +0200
committerJeroen Roovers <jer@gentoo.org>2017-07-26 21:10:44 +0200
commit7442974f018c4f58ca1a25228ab1f01170ff441e (patch)
treedbfe587d8323be84accaaa0e022229c1cbf656e4 /net-libs/wvstreams
parentnet-libs/wvstreams: Fix sed script. (diff)
downloadgentoo-7442974f018c4f58ca1a25228ab1f01170ff441e.tar.gz
gentoo-7442974f018c4f58ca1a25228ab1f01170ff441e.tar.bz2
gentoo-7442974f018c4f58ca1a25228ab1f01170ff441e.zip
net-libs/wvstreams: EAPI bump.
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'net-libs/wvstreams')
-rw-r--r--net-libs/wvstreams/files/wvstreams-4.6.1-_DEFAULT_SOURCE.patch11
-rw-r--r--net-libs/wvstreams/files/wvstreams-4.6.1-autoconf.patch31
-rw-r--r--net-libs/wvstreams/wvstreams-4.6.1-r3.ebuild2
-rw-r--r--net-libs/wvstreams/wvstreams-4.6.1-r4.ebuild95
4 files changed, 138 insertions, 1 deletions
diff --git a/net-libs/wvstreams/files/wvstreams-4.6.1-_DEFAULT_SOURCE.patch b/net-libs/wvstreams/files/wvstreams-4.6.1-_DEFAULT_SOURCE.patch
new file mode 100644
index 000000000000..1084a5be21e3
--- /dev/null
+++ b/net-libs/wvstreams/files/wvstreams-4.6.1-_DEFAULT_SOURCE.patch
@@ -0,0 +1,11 @@
+--- a/wvrules.mk
++++ b/wvrules.mk
+@@ -83,7 +83,7 @@
+
+ INCFLAGS=$(addprefix -I,$(WVSTREAMS_INC) $(XPATH))
+ CPPFLAGS+=$(INCFLAGS) \
+- -D_BSD_SOURCE -D_GNU_SOURCE $(OSDEFINE) \
++ -D_DEFAULT_SOURCE $(OSDEFINE) \
+ -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 \
+ -DUNSTABLE
+
diff --git a/net-libs/wvstreams/files/wvstreams-4.6.1-autoconf.patch b/net-libs/wvstreams/files/wvstreams-4.6.1-autoconf.patch
new file mode 100644
index 000000000000..a9b9a5ac90c1
--- /dev/null
+++ b/net-libs/wvstreams/files/wvstreams-4.6.1-autoconf.patch
@@ -0,0 +1,31 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -641,6 +641,8 @@
+
+ AC_CONFIG_HEADERS(include/wvautoconf.h)
+
++AC_CONFIG_SUBDIRS(argp)
++
+ AC_OUTPUT
+
+ # Now convert PACKAGE_* macros into WVPACKAGE_* in include/wvautoconf.h
+--- a/argp/configure.ac
++++ b/argp/configure.ac
+@@ -4,7 +4,7 @@
+ AC_PREREQ(2.54)
+ AC_INIT(argp-ba.c)
+ AM_INIT_AUTOMAKE(argp, standalone-1.3)
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS(config.h)
+
+ # GNU libc defaults to supplying the ISO C library functions only. The
+ # _GNU_SOURCE define enables these extensions, in particular we want
+@@ -18,7 +18,7 @@
+ AC_PROG_RANLIB
+ AC_PROGRAM_CHECK(AR,ar,ar,:)
+ AC_PROGRAM_CHECK(AR,gar,gar,:)
+-AM_PROG_CC_STDC
++AC_PROG_CC
+
+ AC_SUBST(AR)
+
diff --git a/net-libs/wvstreams/wvstreams-4.6.1-r3.ebuild b/net-libs/wvstreams/wvstreams-4.6.1-r3.ebuild
index af37675388dc..dad2d2f206a9 100644
--- a/net-libs/wvstreams/wvstreams-4.6.1-r3.ebuild
+++ b/net-libs/wvstreams/wvstreams-4.6.1-r3.ebuild
@@ -23,7 +23,7 @@ RESTRICT="test"
RDEPEND="sys-libs/readline:0=
sys-libs/zlib
dbus? ( >=sys-apps/dbus-1.4.20 )
- dev-libs/openssl:0=
+ <dev-libs/openssl-1.1:0=
pam? ( virtual/pam )"
DEPEND="${RDEPEND}
virtual/pkgconfig
diff --git a/net-libs/wvstreams/wvstreams-4.6.1-r4.ebuild b/net-libs/wvstreams/wvstreams-4.6.1-r4.ebuild
new file mode 100644
index 000000000000..df4b00f5a857
--- /dev/null
+++ b/net-libs/wvstreams/wvstreams-4.6.1-r4.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils flag-o-matic toolchain-funcs versionator
+
+DESCRIPTION="A network programming library in C++"
+HOMEPAGE="http://alumnit.ca/wiki/?WvStreams"
+SRC_URI="https://wvstreams.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="pam doc +ssl +dbus debug boost"
+
+#Tests fail if openssl is not compiled with -DPURIFY. Gentoo's isn't. FAIL!
+RESTRICT="test"
+
+#QA Fail: xplc is compiled as a part of wvstreams.
+#It'll take a larger patching effort to get it extracted, since upstream integrated it
+#more tightly this time. Probably for the better since upstream xplc seems dead.
+
+RDEPEND="
+ <dev-libs/openssl-1.1:0=
+ sys-libs/readline:0=
+ sys-libs/zlib
+ dbus? ( >=sys-apps/dbus-1.4.20 )
+ pam? ( virtual/pam )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ boost? ( >=dev-libs/boost-1.34.1:= )
+"
+DOCS="ChangeLog README*"
+PATCHES=(
+ "${FILESDIR}"/${P}-autoconf.patch
+ "${FILESDIR}"/${P}-fix-c++14.patch
+ "${FILESDIR}"/${P}-gcc47.patch
+ "${FILESDIR}"/${P}-glibc212.patch
+ "${FILESDIR}"/${P}-openssl-1.0.0.patch
+ "${FILESDIR}"/${P}-parallel-make.patch
+ "${FILESDIR}"/${P}-_DEFAULT_SOURCE.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+ append-flags -fno-tree-dce -fno-optimize-sibling-calls #421375
+
+ tc-export AR CXX
+
+ use boost && export ac_cv_header_tr1_functional=no
+
+ econf \
+ $(use_enable debug) \
+ $(use_with dbus) \
+ $(use_with pam) \
+ --cache-file=${T}/config.cache \
+ --disable-optimization \
+ --localstatedir=/var \
+ --with-openssl \
+ --with-zlib \
+ --without-qt \
+ --without-tcl \
+ --without-valgrind
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ doxygen || die
+ fi
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ #the list of files is too big for dohtml -r Docs/doxy-html/*
+ docinto html
+ dodoc -r Docs/doxy-html/*
+ fi
+}