summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-09-18 19:47:24 +0200
committerMarek Szuba <marecki@gentoo.org>2020-09-18 19:47:24 +0200
commit3db80ff763450278cc2ae3391e1be8bc2fd11b7e (patch)
tree9e33224814a63687572148268545c4e8aa99e3aa /net-libs/xrootd-ceph/xrootd-ceph-4.12.4.ebuild
parentnet-libs/xrootd: remove old (diff)
downloadgentoo-3db80ff763450278cc2ae3391e1be8bc2fd11b7e.tar.gz
gentoo-3db80ff763450278cc2ae3391e1be8bc2fd11b7e.tar.bz2
gentoo-3db80ff763450278cc2ae3391e1be8bc2fd11b7e.zip
net-libs/xrootd-ceph: bump to 4.12.4
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs/xrootd-ceph/xrootd-ceph-4.12.4.ebuild')
-rw-r--r--net-libs/xrootd-ceph/xrootd-ceph-4.12.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-libs/xrootd-ceph/xrootd-ceph-4.12.4.ebuild b/net-libs/xrootd-ceph/xrootd-ceph-4.12.4.ebuild
new file mode 100644
index 000000000000..f701427b94c7
--- /dev/null
+++ b/net-libs/xrootd-ceph/xrootd-ceph-4.12.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="xrootd OSS plug-in for interfacing with Ceph storage platform"
+HOMEPAGE="https://xrootd.slac.stanford.edu/"
+SRC_URI="https://github.com/xrootd/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux"
+
+DEPEND="net-libs/xrootd
+ !<net-libs/xrootd-4.10.0[rbd]
+ sys-cluster/ceph"
+RDEPEND="${DEPEND}"
+
+# xrootd plugins are not intended to be linked with,
+# they are to be loaded at runtime by xrootd,
+# see https://github.com/xrootd/xrootd/issues/447
+QA_SONAME="/usr/lib.*/libXrd.*-$(ver_cut 1).so"