summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-10-16 12:58:34 +0200
committerMarek Szuba <marecki@gentoo.org>2020-10-16 12:59:12 +0200
commit529ce44c7bd7b6eb666a6a0ef4014f4d917f29ec (patch)
treeab50dfba3ec0e567683772b3170b3173436286ad /net-libs/xrootd-ceph/xrootd-ceph-4.12.5.ebuild
parentnet-libs/xrootd: bump to 4.12.5 (diff)
downloadgentoo-529ce44c7bd7b6eb666a6a0ef4014f4d917f29ec.tar.gz
gentoo-529ce44c7bd7b6eb666a6a0ef4014f4d917f29ec.tar.bz2
gentoo-529ce44c7bd7b6eb666a6a0ef4014f4d917f29ec.zip
net-libs/xrootd-ceph: bump to 4.12.5
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs/xrootd-ceph/xrootd-ceph-4.12.5.ebuild')
-rw-r--r--net-libs/xrootd-ceph/xrootd-ceph-4.12.5.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-libs/xrootd-ceph/xrootd-ceph-4.12.5.ebuild b/net-libs/xrootd-ceph/xrootd-ceph-4.12.5.ebuild
new file mode 100644
index 000000000000..f701427b94c7
--- /dev/null
+++ b/net-libs/xrootd-ceph/xrootd-ceph-4.12.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="xrootd OSS plug-in for interfacing with Ceph storage platform"
+HOMEPAGE="https://xrootd.slac.stanford.edu/"
+SRC_URI="https://github.com/xrootd/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux"
+
+DEPEND="net-libs/xrootd
+ !<net-libs/xrootd-4.10.0[rbd]
+ sys-cluster/ceph"
+RDEPEND="${DEPEND}"
+
+# xrootd plugins are not intended to be linked with,
+# they are to be loaded at runtime by xrootd,
+# see https://github.com/xrootd/xrootd/issues/447
+QA_SONAME="/usr/lib.*/libXrd.*-$(ver_cut 1).so"