summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-08-24 14:42:36 +0200
committerMarek Szuba <marecki@gentoo.org>2020-08-24 19:07:13 +0200
commit862ed3c99a7abdd2c8f4abe887714626ff442e23 (patch)
treeb5db041f3d9ffb0e7ca530c6374f6803b7c69e1f /net-libs/xrootd
parentnet-p2p/syncthing: bump to 1.8.0 (diff)
downloadgentoo-862ed3c99a7abdd2c8f4abe887714626ff442e23.tar.gz
gentoo-862ed3c99a7abdd2c8f4abe887714626ff442e23.tar.bz2
gentoo-862ed3c99a7abdd2c8f4abe887714626ff442e23.zip
net-libs/xrootd: bump to 5.0.1
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs/xrootd')
-rw-r--r--net-libs/xrootd/Manifest1
-rw-r--r--net-libs/xrootd/xrootd-5.0.1.ebuild116
2 files changed, 117 insertions, 0 deletions
diff --git a/net-libs/xrootd/Manifest b/net-libs/xrootd/Manifest
index 1468396eec70..09415fd4e670 100644
--- a/net-libs/xrootd/Manifest
+++ b/net-libs/xrootd/Manifest
@@ -1,3 +1,4 @@
DIST xrootd-4.12.0.tar.gz 2564041 BLAKE2B 6ea9c379aa482c81279168baa3e1381e880d34014fb3516c96961da64d54faf649295f024313ece445df9a62b6b5c818b7aa8a987025d3cd969188de072648c9 SHA512 5338c4fb5461918473dd4f41f4d29fae09a8fc6a9e2d8f00bb74d929dc5396fef73643462d1a4f1ba71ffe5cf92a1695a167ca3a766c674a9377dcf99aaa1778
DIST xrootd-4.12.3.tar.gz 2574996 BLAKE2B 1ba6ecdee473fbe1f6367459dfe8324f38e2d72aa64ed349ccdcaa7616a3d70f0b647d2eac6babbcc0e1b673ff44a050c05f23e80fb89161f121fa6dd3484311 SHA512 e4f4ad744a71a7fc69a16f2114b6d5962ddf0b22bd86f7eb19703313d55242813f13be1a1f23c541b966674bdb4854f955843322525f37bc83647e8f2fbe076d
DIST xrootd-5.0.0.tar.gz 2754256 BLAKE2B c80a38ede3263ae669181f2173f6ee2bb0a347dc973cecc9dedf00867041190f7bceb7f475696e8cd3921c57d4c197b73ee57b29c9e78a027393ca61dca1b6d3 SHA512 75b69d3da2a6e477edbf5588afd943a91a2e1e86fcc98afc34d964c9231fc0224b4eec82336e9a7d5bd8bd0cd5c20e442ee37b8f6239f417b05efdf39038d93c
+DIST xrootd-5.0.1.tar.gz 2759931 BLAKE2B 2bc76f660f7fb3c9202c37dc10f099f2bd06868b00c43e6015ebb0d9cf3edf8ac777f76c1f71d0f1f4b252cedd62c9aa74a449cb5f369492a5ee63813bb7924f SHA512 95e0fe97f66a320999d4c2dd2ac5be4e2ba7779f220aa521e4882925d5e9262c34991f0ecbd3c2449b97977ff4cdbdcd9477ed780d1a6dbf8fbd3f547b4932ba
diff --git a/net-libs/xrootd/xrootd-5.0.1.ebuild b/net-libs/xrootd/xrootd-5.0.1.ebuild
new file mode 100644
index 000000000000..b96f560be940
--- /dev/null
+++ b/net-libs/xrootd/xrootd-5.0.1.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+# Upstream does not support the building of Python bindings
+# via CMake for more than one implementation at a time.
+inherit cmake python-single-r1
+
+DESCRIPTION="Extended ROOT remote file server"
+HOMEPAGE="http://xrootd.org/"
+SRC_URI="http://xrootd.org/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples fuse http kerberos python readline ssl test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="acct-group/xrootd
+ acct-user/xrootd
+ sys-libs/zlib
+ fuse? ( sys-fs/fuse:= )
+ kerberos? ( virtual/krb5 )
+ python? ( ${PYTHON_DEPS} )
+ readline? ( sys-libs/readline:0= )
+ ssl? ( dev-libs/openssl:0= )
+"
+DEPEND="${CDEPEND}"
+BDEPEND="
+ doc? (
+ app-doc/doxygen[dot]
+ python? ( dev-python/sphinx )
+ )
+ test? ( dev-util/cppunit )
+"
+RDEPEND="${CDEPEND}
+ dev-lang/perl
+"
+REQUIRED_USE="
+ http? ( kerberos ssl )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+PATCHES=( "${FILESDIR}"/xrootd-4.8.3-crc32.patch )
+
+# xrootd plugins are not intended to be linked with,
+# they are to be loaded at runtime by xrootd,
+# see https://github.com/xrootd/xrootd/issues/447
+QA_SONAME="/usr/lib.*/libXrd.*-$(ver_cut 1)\.so
+ /usr/lib.*/libXrdClTests\.so"
+
+pkg_setup() {
+ use python && python_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CRYPTO=$(usex ssl)
+ -DENABLE_FUSE=$(usex fuse)
+ -DENABLE_HTTP=$(usex http)
+ -DENABLE_KRB5=$(usex kerberos)
+ -DENABLE_PYTHON=$(usex python)
+ -DENABLE_READLINE=$(usex readline)
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ if use doc; then
+ doxygen Doxyfile || die
+ if use python; then
+ emake -C bindings/python/docs html
+ fi
+ fi
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doxydoc/html/. )
+ dodoc docs/ReleaseNotes.txt
+ cmake_src_install
+ find "${D}" \( -iname '*.md5' -o -iname '*.map' \) -delete || die
+
+ # base configs
+ insinto /etc/xrootd
+ doins packaging/common/*.cfg
+
+ fowners root:xrootd /etc/xrootd
+ keepdir /var/log/xrootd
+ fowners xrootd:xrootd /var/log/xrootd
+
+ local i
+ for i in cmsd frm_purged frm_xfrd xrootd; do
+ newinitd "${FILESDIR}"/${i}.initd ${i}
+ done
+ # all daemons MUST use single master config file
+ newconfd "${FILESDIR}"/xrootd.confd xrootd
+
+ if use python; then
+ python_optimize "${D}/$(python_get_sitedir)"
+
+ if use doc; then
+ docinto python
+ docompress -x "/usr/share/doc/${PF}/python/html"
+ dodoc -r bindings/python/docs/build/html
+ fi
+ if use examples; then
+ docinto python
+ dodoc -r bindings/python/examples
+ fi
+ fi
+}