summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-02-25 15:32:53 +0000
committerMarek Szuba <marecki@gentoo.org>2021-02-25 15:34:31 +0000
commitc3dc71f1ada3ce6853c92f24cd44704d2cdff79b (patch)
treef0eac9b12eb1ff4fbfd7a9bd01e8ba7d7489bb59 /net-libs/xrootd
parentgames-engines/devilutionx: Added "hellfire" USE flag (diff)
downloadgentoo-c3dc71f1ada3ce6853c92f24cd44704d2cdff79b.tar.gz
gentoo-c3dc71f1ada3ce6853c92f24cd44704d2cdff79b.tar.bz2
gentoo-c3dc71f1ada3ce6853c92f24cd44704d2cdff79b.zip
net-libs/xrootd: bump to 5.1.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs/xrootd')
-rw-r--r--net-libs/xrootd/Manifest1
-rw-r--r--net-libs/xrootd/xrootd-5.1.0.ebuild116
2 files changed, 117 insertions, 0 deletions
diff --git a/net-libs/xrootd/Manifest b/net-libs/xrootd/Manifest
index dbc6b0153389..3d44fe265d5e 100644
--- a/net-libs/xrootd/Manifest
+++ b/net-libs/xrootd/Manifest
@@ -2,3 +2,4 @@ DIST xrootd-4.12.4.tar.gz 2577360 BLAKE2B f2e4413bcbf02dccb1ac7b0ceec8fbc2bb8b1d
DIST xrootd-4.12.5.tar.gz 2580794 BLAKE2B 217abb8ad332b3eb0cbe2289f4fa7c31abce7c3122ef8d23f409a3a03b7691f0e8a1939a42c831774e6902bf0f3242a2583bbf010478a66f5a2e634008799c5b SHA512 c252866ccdc4465c9ffe3f5cb4bb83a2a70e775db5ff3a55bcd8ac70c72d280ea41fb31501f30550d8ac61b6d474ce602e0ee8a02485f1f2722617aeb25aff0d
DIST xrootd-5.0.2.tar.gz 2764503 BLAKE2B 35bc642d3601738135ff24a77f9bc8795568553856284ebe80d90315039d04109353d2e00310f8b8168f6b1176ee295c9116a7e6adaff33ca23383da9deecf17 SHA512 e58b5484c0fa9f83643e252eb8228f2061130b4f97964283a6adb8a81560841f3d44814572136023d944be6bdd97cff551e75bbfb04e6c9aafaa779ecb051255
DIST xrootd-5.0.3.tar.gz 2766694 BLAKE2B 1fe7743de4d09c95257c3d761c2056024ba3ba59b7cd86b5926f2d32cc2f85dcd0af69e6e5969967591a2bba293902b757395e0f9375cbbbb39577eed9e450eb SHA512 e085af48e4196a44e9ebd63bf1234cf4401f158d23d03ffb38fcfe43284d025abe6c0b5e46b2808b28f300b933ff12523f64ac2d86d3f344aa2e0aea95e30cb0
+DIST xrootd-5.1.0.tar.gz 2862622 BLAKE2B cb166adcd60b263f7fbed22033fe362ed5b32b7a05c76ff2d8a5ab25d730673d0c5d22bc41816083c84c3f14832cca34d801738594c7b58dcebbea9882a7df37 SHA512 f9bb293433e16b86d3395f29cf23f10a4a5447b367aa762219559278b3f75402892be85e0ca914762bfe892ad0dcc05bcfc64ac1ad0316c5855586141b537bad
diff --git a/net-libs/xrootd/xrootd-5.1.0.ebuild b/net-libs/xrootd/xrootd-5.1.0.ebuild
new file mode 100644
index 000000000000..1aeb46c6bf10
--- /dev/null
+++ b/net-libs/xrootd/xrootd-5.1.0.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+# Upstream does not support the building of Python bindings
+# via CMake for more than one implementation at a time.
+inherit cmake python-single-r1
+
+DESCRIPTION="Extended ROOT remote file server"
+HOMEPAGE="http://xrootd.org/"
+SRC_URI="http://xrootd.org/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples fuse http kerberos python readline ssl test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="acct-group/xrootd
+ acct-user/xrootd
+ sys-libs/zlib
+ fuse? ( sys-fs/fuse:= )
+ kerberos? ( virtual/krb5 )
+ python? ( ${PYTHON_DEPS} )
+ readline? ( sys-libs/readline:0= )
+ ssl? ( dev-libs/openssl:0= )
+"
+DEPEND="${CDEPEND}"
+BDEPEND="
+ doc? (
+ app-doc/doxygen[dot]
+ python? ( dev-python/sphinx )
+ )
+ test? ( dev-util/cppunit )
+"
+RDEPEND="${CDEPEND}
+ dev-lang/perl
+"
+REQUIRED_USE="
+ http? ( kerberos ssl )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+PATCHES=( "${FILESDIR}"/xrootd-4.8.3-crc32.patch )
+
+# xrootd plugins are not intended to be linked with,
+# they are to be loaded at runtime by xrootd,
+# see https://github.com/xrootd/xrootd/issues/447
+QA_SONAME="/usr/lib.*/libXrd.*-$(ver_cut 1)\.so
+ /usr/lib.*/libXrdClTests\.so"
+
+pkg_setup() {
+ use python && python_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CRYPTO=$(usex ssl)
+ -DENABLE_FUSE=$(usex fuse)
+ -DENABLE_HTTP=$(usex http)
+ -DENABLE_KRB5=$(usex kerberos)
+ -DENABLE_PYTHON=$(usex python)
+ -DENABLE_READLINE=$(usex readline)
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ if use doc; then
+ doxygen Doxyfile || die
+ if use python; then
+ emake -C bindings/python/docs html
+ fi
+ fi
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doxydoc/html/. )
+ dodoc docs/ReleaseNotes.txt
+ cmake_src_install
+ find "${D}" \( -iname '*.md5' -o -iname '*.map' \) -delete || die
+
+ # base configs
+ insinto /etc/xrootd
+ doins packaging/common/*.cfg
+
+ fowners root:xrootd /etc/xrootd
+ keepdir /var/log/xrootd
+ fowners xrootd:xrootd /var/log/xrootd
+
+ local i
+ for i in cmsd frm_purged frm_xfrd xrootd; do
+ newinitd "${FILESDIR}"/${i}.initd ${i}
+ done
+ # all daemons MUST use single master config file
+ newconfd "${FILESDIR}"/xrootd.confd xrootd
+
+ if use python; then
+ python_optimize "${D}/$(python_get_sitedir)"
+
+ if use doc; then
+ docinto python
+ docompress -x "/usr/share/doc/${PF}/python/html"
+ dodoc -r bindings/python/docs/build/html
+ fi
+ if use examples; then
+ docinto python
+ dodoc -r bindings/python/examples
+ fi
+ fi
+}