summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathy Vanvoorden <mathy@vanvoorden.be>2017-12-01 10:13:37 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-02-20 22:38:47 +0100
commitef6e13761d2ab6ef7929ac5c3af8c02519f0306c (patch)
treece0396bbf5bf95501188bcd760c005a86b6cdd26 /net-libs/zmqpp/zmqpp-4.2.0.ebuild
parentdev-db/phpmyadmin: Security bump to address PMASA-2018-1 (CVE-2018-7260). (diff)
downloadgentoo-ef6e13761d2ab6ef7929ac5c3af8c02519f0306c.tar.gz
gentoo-ef6e13761d2ab6ef7929ac5c3af8c02519f0306c.tar.bz2
gentoo-ef6e13761d2ab6ef7929ac5c3af8c02519f0306c.zip
net-libs/zmqpp: version bump to 4.2.0.
Package-Manager: Portage-2.3.14, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/6368
Diffstat (limited to 'net-libs/zmqpp/zmqpp-4.2.0.ebuild')
-rw-r--r--net-libs/zmqpp/zmqpp-4.2.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-libs/zmqpp/zmqpp-4.2.0.ebuild b/net-libs/zmqpp/zmqpp-4.2.0.ebuild
new file mode 100644
index 000000000000..e60bfa0f62c0
--- /dev/null
+++ b/net-libs/zmqpp/zmqpp-4.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="ZeroMQ 'highlevel' C++ bindings"
+HOMEPAGE="https://github.com/zeromq/zmqpp"
+if [[ $PV == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zeromq/zmqpp.git"
+else
+ SRC_URI="https://github.com/zeromq/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+IUSE="static-libs"
+
+DEPEND="net-libs/zeromq[static-libs?]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DIS_TRAVIS_CI_BUILD=OFF
+ -DZMQPP_BUILD_SHARED=ON
+ $(cmake-utils_use static-libs ZMQPP_BUILD_STATIC)
+ )
+
+ cmake-utils_src_configure
+}