summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-10-14 23:30:26 -0400
committerMike Frysinger <vapier@gentoo.org>2015-10-14 23:30:33 -0400
commit042312d793e67f729bd2f332a506bdd7352b335c (patch)
treef3200922a90e2ea35c73ffe871f584c5c4301d60 /net-libs
parentapp-i18n/poedit: Version bump, bug #563048 by Oleg. (diff)
downloadgentoo-042312d793e67f729bd2f332a506bdd7352b335c.tar.gz
gentoo-042312d793e67f729bd2f332a506bdd7352b335c.tar.bz2
gentoo-042312d793e67f729bd2f332a506bdd7352b335c.zip
net-libs/nghttp2: version bump to 1.3.4 #563044
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.3.4.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index abad930cf588..eb8b28a2c418 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -1,3 +1,4 @@
DIST nghttp2-1.0.5.tar.gz 1356748 SHA256 64e066816606178188bfaf0aa7298e1f44cef943dd9ae936497dab38b3b2569e SHA512 f8b7a79e6174ff501d93333b25954822098d936720a8f4de8a15c83f16c009006aefd05e24977c219661fd63b9fead70eaf5703211bfd9e2bba6a61facbba9c4 WHIRLPOOL 608b1a4494e2aff0c941545c1f49c3c585846d27f5e509ff16c9217309689c47fd7f8fc398b23c83d8aa0ba3f9c2c52af039cd875e47f38630acc50e7c17f717
DIST nghttp2-1.2.1.tar.gz 1399177 SHA256 133451219eacbdd7e37438dd63296e037621a3323d5c8446c35f0c89ab665c7e SHA512 3d7621243f037f4ec6143dcc3f0ad3489faf3a94ce409909eea47dbb59f2a1d80eaf295c59f7fccc2501f26d706c2355c4c26d8c9649c1479dbc4feac2846800 WHIRLPOOL 9a83045f5f619700db7715f048e0e0958552abfc2248f398880b85d278c12b5789810596a724823d903993f39025f49f7e68ce386220ed6fbfa35bd914a549a5
DIST nghttp2-1.3.2.tar.gz 1824304 SHA256 aeafb76acf246352cc0638fbfb8eff999fef7cf18a5bf01a6a77b0af35d14b28 SHA512 85cc1be056dae8c479c6e45d69b52ad575d7e82c271ed8c27548639d5a167c79986a2bb4ffdbe4a0112732b57635c8f6ca38436b5b19faadbe2e8d5dc7b1d8f5 WHIRLPOOL badd7a0062ae6a4400a8a7ef3381b36844c22d44ac84de718ffea0d305bc402fd105452a482f7e8e607c88d674193f015d66b868e0d9c26ff2fe20465bbc1eb2
+DIST nghttp2-1.3.4.tar.gz 1836736 SHA256 70da762f021ca6a56912da112f414da8100b035e635bfb056fcf35289229e9ce SHA512 ef47d25f1f214a4f79b4873567f799ec1f9ebb432e57b5f1106fcf0f1a1c0365176125273c7c7a36e826ede43c356413d143f09204206c41dc90c33a1ce33801 WHIRLPOOL e426530bb98a8006dd3ffcd57a151f6c4952c203500c34ee6ebe3ded8a4a44d2d5582763aeb80d373fbd602e0df3e0eefb852d8b98e24b8aa6f3fd68894752a3
diff --git a/net-libs/nghttp2/nghttp2-1.3.4.ebuild b/net-libs/nghttp2/nghttp2-1.3.4.ebuild
new file mode 100644
index 000000000000..7ef717f44ed6
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.3.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# TODO: Add python support.
+
+EAPI="5"
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/tatsuhiro-t/nghttp2.git"
+ inherit git-2
+else
+ SRC_URI="https://github.com/tatsuhiro-t/nghttp2/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
+
+RDEPEND="
+ cxx? ( dev-libs/boost[${MULTILIB_USEDEP},threads] )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc )
+ utils? (
+ >=dev-libs/libev-4.15
+ !libressl? ( >=dev-libs/openssl-1.0.2:0 )
+ libressl? ( dev-libs/libressl )
+ >=sys-libs/zlib-1.2.3
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-examples \
+ --disable-failmalloc \
+ --disable-werror \
+ --without-cython \
+ --disable-python-bindings \
+ --without-spdylay \
+ $(use_enable cxx asio-lib) \
+ $(use_enable debug) \
+ $(multilib_native_use_enable hpack-tools) \
+ $(use_enable static-libs static) \
+ $(use_enable threads) \
+ $(multilib_native_use_enable utils app) \
+ $(multilib_native_use_with jemalloc) \
+ $(multilib_native_use_with xml libxml2)
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED}" -name '*.la' -delete
+}