summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-02-06 10:45:16 +0100
committerJeroen Roovers <jer@gentoo.org>2020-02-06 10:45:38 +0100
commit0568522402f52171c85e5f227d0ac7e826051e64 (patch)
tree65966b621e11d407ded83d459752f612309d5223 /net-libs
parentmedia-libs/opus: stable 1.3.1-r1 for ppc64, bug #708324 (diff)
downloadgentoo-0568522402f52171c85e5f227d0ac7e826051e64.tar.gz
gentoo-0568522402f52171c85e5f227d0ac7e826051e64.tar.bz2
gentoo-0568522402f52171c85e5f227d0ac7e826051e64.zip
net-libs/http-parser: Version 2.9.3
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/http-parser/Manifest1
-rw-r--r--net-libs/http-parser/http-parser-2.9.3.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/net-libs/http-parser/Manifest b/net-libs/http-parser/Manifest
index 33944819ad5a..14a6a94c5f11 100644
--- a/net-libs/http-parser/Manifest
+++ b/net-libs/http-parser/Manifest
@@ -1,3 +1,4 @@
DIST http-parser-2.8.1.tar.gz 50731 BLAKE2B 1c4f3f61550f7f8e86d7b47e3986754a108dc979c6232d87ac418f9f8295b88ee43c4a5af150460f707e6ade01f5d435801f980ccbff93369ee0a9dc2eb60656 SHA512 6f52f543d979f39688ccefae236527a8183929b3d30f5370570107b01cf89d0338b448249a81102b78d31615d2e8f6e7c708f8961f55ece08e7d3a40e5ad0883
DIST http-parser-2.9.1.tar.gz 51300 BLAKE2B f99c3e6a764ea0870359b43aac7f31691faef9cc6be3fb99426a3c1e3f24ae50689dfd8e46fa52a22d713780476130ee6fae6294b83cc3526bb5131cf16b98f2 SHA512 110a1861666cdd45857c3ab0e9bf8a3eb9d98f86fe001f7c620009e13186377de805d295f7751921cd5c9d4c2781807b3ae00f939af04d7365a3a45aa20b5052
DIST http-parser-2.9.2.tar.gz 51298 BLAKE2B 5d37ea197acbac468de03081010fb3b755a093085e56c9fa5a3d4dbd70dd2903335a8113ec21664ca54a74aac4cbbb1cc64b861d021df944790453c2de9baaab SHA512 fe21ba46c9297b55a6382497b689da2af88999a9a5716ffef0731057ce1bb053056e4f20147284c78338e48ed1a793a0270fe0edfe3f4b589926e3ede603d023
+DIST http-parser-2.9.3.tar.gz 51973 BLAKE2B c46160e811874f3d4d2a7390e3b64520c7c01d51f74fb608ca8972ffe264cc389b744c1b6d8b5b6a7c9d7816eb95c179a9c210ba1a122ac4fa95996308d667af SHA512 d200c52f594192ba80a8d5b59d414404843f8601dac647f29c27845db75ac1f015789031e30e91aaab5b553af1ee6af50b90f9342a444c10c1027e10fdb9a31b
diff --git a/net-libs/http-parser/http-parser-2.9.3.ebuild b/net-libs/http-parser/http-parser-2.9.3.ebuild
new file mode 100644
index 000000000000..28a3330d367a
--- /dev/null
+++ b/net-libs/http-parser/http-parser-2.9.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs multilib-minimal
+
+DESCRIPTION="HTTP request/response parser for C"
+HOMEPAGE="https://github.com/nodejs/http-parser"
+SRC_URI="https://github.com/nodejs/http-parser/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/2.9.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x64-macos ~x64-solaris"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ tc-export CC AR
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" CFLAGS_FAST="${CFLAGS}" library
+ use static-libs && emake CFLAGS_FAST="${CFLAGS}" package
+}
+
+multilib_src_test() {
+ emake CFLAGS_DEBUG="${CFLAGS}" CFLAGS_FAST="${CFLAGS}" test
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" install
+ use static-libs && dolib.a libhttp_parser.a
+}