summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2017-09-25 05:23:05 +0000
committerPatrick Lauer <patrick@gentoo.org>2017-09-25 06:44:19 +0000
commit169a7de97d0c832a2c4f327fd3f67ce8b3460294 (patch)
tree4bbc203705f06363e75f87b9aa04e2b67c51d0e7 /net-libs
parentdev-lang/mercury: fix XDG_xxx_DIR sandbox issue. Bug #575140 (diff)
downloadgentoo-169a7de97d0c832a2c4f327fd3f67ce8b3460294.tar.gz
gentoo-169a7de97d0c832a2c4f327fd3f67ce8b3460294.tar.bz2
gentoo-169a7de97d0c832a2c4f327fd3f67ce8b3460294.zip
net-libs/gsoap: Bump
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gsoap/Manifest1
-rw-r--r--net-libs/gsoap/gsoap-2.8.54.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/net-libs/gsoap/Manifest b/net-libs/gsoap/Manifest
index a3d3bc2415eb..6bb7db2a4691 100644
--- a/net-libs/gsoap/Manifest
+++ b/net-libs/gsoap/Manifest
@@ -1,3 +1,4 @@
DIST gsoap_2.8.40.zip 36317175 SHA256 54ef56d9c55a6a7a00ae57f8cb0b3266af1b26e623070be2ef20833626157f77 SHA512 fc26899e780a7d797544f21aa7beaabc6c1507b7097c4a229a641e4be763733a40e96ce0d5181024eae19653de9513a5b35d51c8b12e85078423e30d0b898a6f WHIRLPOOL 6f795590a5b1e36d796200e3669b3a2aa45c016aa3acaae6291c09543422530a12e977a159a2f892b328cd7813633f41966432e75fd36268bfe4c6d9d1bb6fbf
DIST gsoap_2.8.51.zip 34505931 SHA256 3e7bb24a9e492f5cb86daca34054c9787152f1d7b70add36b789d03816d5ffa1 SHA512 491e31ce6be02c577b6184335672a0805e2287418a7e26d9b0f009aab8af462ddef7d7a1893dc867db5362c5f2a1e0022d0a45865d81e43286ce16c649da6910 WHIRLPOOL 78bf9dd3c20e3a7683e20de263c1f608e69039ae505533dc7695dd1b0031d222ea99ca3991e8b046af66943215a7ce4c4db3a0efafc6933d74907dda71815d05
DIST gsoap_2.8.52.zip 34464252 SHA256 96ad6ce7be175742e693b19e3d72e0f04752a70845c7e0ad539cb882f2e7800a SHA512 ec08b8f49651e51754f5a404db83e1fb9d636bf84646cb9783be4aaf8c1b60adfb6f25722b2bdd55fb6812a9943296b1e9569e3b33df50d2d93a7a4494d13d55 WHIRLPOOL b2caa3fad3c33b3bb86a145fdec37da7a2be2e0dc2f40c9fa6b5352c1657190464a78c0ce9d047de03a5a5a9ff7701354ac2e1c938bd9a56fe0c3731d397fc4c
+DIST gsoap_2.8.54.zip 34520149 SHA256 158ed9c674941c382850e8e96ac9b0174f4e7aacb25794349bd07f52261921c8 SHA512 59e59dbcb0c7b6f13771c0cd26412941da0a15e05c539dcfaa7deecd83e15b50656454daf6c80eefb85e2d8830748a4fd48970e6de68fd1e2b96ce9a7c0d1874 WHIRLPOOL d49c92051c27b1db0a4e07c2767c2e62b1524b65a3f3198d00e4b7ff19105e5afcd87bc2616d0ccd5cea8534da9f212c54ba9ca9fd6a8bfc9ae90cf1c64b6dda
diff --git a/net-libs/gsoap/gsoap-2.8.54.ebuild b/net-libs/gsoap/gsoap-2.8.54.ebuild
new file mode 100644
index 000000000000..28cf845a3274
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.8.54.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils
+
+MY_P="${PN}-2.8"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK for SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples ipv6 libressl gnutls +ssl"
+
+RDEPEND="
+ sys-libs/zlib
+ gnutls? ( net-libs/gnutls )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl )
+ )
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+"
+
+PATCHES=(
+ # Fix Pre-ISO headers
+ "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ # enable shared libs https://bugs.gentoo.org/583398
+ "${FILESDIR}/${PN}-2.8.52-shared_libs.patch"
+)
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=()
+ use ssl || myconf+=( --disable-ssl )
+ use gnutls && myconf+=( --enable-gnutls )
+ use ipv6 && myconf+=( --enable-ipv6 )
+ econf \
+ ${myconf[@]} \
+ $(use_enable debug) \
+ $(use_enable examples samples)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ dohtml changelog.md
+
+ prune_libtool_files --all
+
+ if use examples; then
+ rm -rf gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o || die
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ dohtml -r gsoap/doc/*
+ fi
+}