summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-28 20:19:20 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-29 00:20:53 +0100
commit23369936de993a813292ce0a06b9571f84da2de0 (patch)
tree24d542952e977ba58d053d6f8c316474391e68d5 /net-libs
parentnet-dns/resolv_wrapper: add 1.1.8 (diff)
downloadgentoo-23369936de993a813292ce0a06b9571f84da2de0.tar.gz
gentoo-23369936de993a813292ce0a06b9571f84da2de0.tar.bz2
gentoo-23369936de993a813292ce0a06b9571f84da2de0.zip
net-libs/socket_wrapper: add 1.4.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/socket_wrapper/Manifest1
-rw-r--r--net-libs/socket_wrapper/socket_wrapper-1.4.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/net-libs/socket_wrapper/Manifest b/net-libs/socket_wrapper/Manifest
index bb5c6e5a9eca..66d1f6662ab1 100644
--- a/net-libs/socket_wrapper/Manifest
+++ b/net-libs/socket_wrapper/Manifest
@@ -1 +1,2 @@
DIST socket_wrapper-1.3.4.tar.gz 81997 BLAKE2B 5d290ef59c16fbdde362749196cc91c3f050518f82cb14fbafa3e00d5fb51a6b085b94b08413ca601731440d8eadb5dfbe8d011567fd67b1240b0cc380504813 SHA512 6e6a940e26d0f4dc4f1c0f84643d5a124bb2cccd1713481e9c42ea7986884928d736b1ef8da8a2aef3d3803938b6e1ebd30bdbe9784fda95a9a59cdbd1d19f61
+DIST socket_wrapper-1.4.0.tar.gz 87353 BLAKE2B 67c2a4bae2e1031399137e404e95e6e6cfa1143ff659a7d34533e908f9169b8a79d1dfffaa51a6280a8cfc9e03dc07585ff41b0e087527b1ad0bb5adb282156e SHA512 944e5ff2b6919e414f9045fe294b9b4813272fe7c00f5ac144c999b99572be6b3ed2eb975ec1d07bd853cffea6dffe339280e4961520d34667f808f76b47db57
diff --git a/net-libs/socket_wrapper/socket_wrapper-1.4.0.ebuild b/net-libs/socket_wrapper/socket_wrapper-1.4.0.ebuild
new file mode 100644
index 000000000000..b719ee9e2057
--- /dev/null
+++ b/net-libs/socket_wrapper/socket_wrapper-1.4.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="Library passing all socket communications through unix sockets"
+HOMEPAGE="https://cwrap.org/socket_wrapper.html"
+SRC_URI="https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( >=dev-util/cmocka-1.1.0 )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUNIT_TESTING=$(usex test ON OFF)
+ )
+ cmake-multilib_src_configure
+}