summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-05-21 16:37:23 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-05-21 16:37:23 +0200
commit390471c1ac9d6d81f5e06726aeef9e2a736f731f (patch)
tree21a07ef8321b62f5db1046afd0f7151af371cb17 /net-libs
parentsys-auth/pam_ssh_agent_auth: Drop old (diff)
downloadgentoo-390471c1ac9d6d81f5e06726aeef9e2a736f731f.tar.gz
gentoo-390471c1ac9d6d81f5e06726aeef9e2a736f731f.tar.bz2
gentoo-390471c1ac9d6d81f5e06726aeef9e2a736f731f.zip
net-libs/gsoap: Bump to version 2.8.84
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gsoap/Manifest1
-rw-r--r--net-libs/gsoap/gsoap-2.8.84.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/net-libs/gsoap/Manifest b/net-libs/gsoap/Manifest
index 3c4a10fa6835..828f587048f1 100644
--- a/net-libs/gsoap/Manifest
+++ b/net-libs/gsoap/Manifest
@@ -1,3 +1,4 @@
DIST gsoap_2.8.70.zip 32695627 BLAKE2B 6d803441804badf06b29cee8ca898dc864b9a0388f6f3fa58b84c1b237d77e22ab70e0cc5439915c715bdba7831b14f86d8003e1338b6184ddbfe845bb76ff75 SHA512 f7e9f85580c19bb390f1310bb47b690a5788b54c1e12c6fc0d9166039a84ae24ec5d3268cb67cd72b20e2eaa78689e175b975f07da44fd20e172a77ef37f4ae7
DIST gsoap_2.8.82.zip 32514214 BLAKE2B 4945fc9e8c6fcbf364235c31aaf5eff5546b4f927a69cc973ba9e855a97ba2e40af2823448c2ea7d371aafea3ea6f6a71cc2d0527049fea53a2d6e1bbeecceec SHA512 daf6a1870fe43beb20d0faf646b171c92629885708baabea5bbce79fa5a8030f014dbe5c0bf4024031df993dd3ed3a90449db813946cfdfa9c12318096b57eec
DIST gsoap_2.8.83.zip 32703770 BLAKE2B 1750a25bcd38c020c83d644395e9b3ac3e0c1080fb82f26b11ea0d0beea98c7dc8f3f24a77e093c6ac7e3598d416430990105eeb93e565809844825e1e937ec1 SHA512 7f4ae6feea26ec2d0e970e77cf476a0049c2e3fe47feba4e3b3b57239e7ae0016c409a74d3e865e56d2c01a8098be282d74a33c686d177d203cb8c2dff6bc407
+DIST gsoap_2.8.84.zip 32538551 BLAKE2B cab2b75ac931ee6063af47975665f45514cb94f5514fb1f76d17ccb2e71d64d4ebd43543cc004ff7f5c49982975ebaa38e555e3bc45dbc370aae991bc7639273 SHA512 ec050119cd3e480b266cad36823f4862fe0ac21045ce901c3c91a552eae2fbf9e1cd515458835807cce54c04df7835a980a299d37f418190cd57684fd6bdcf79
diff --git a/net-libs/gsoap/gsoap-2.8.84.ebuild b/net-libs/gsoap/gsoap-2.8.84.ebuild
new file mode 100644
index 000000000000..a36f6c5466c9
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.8.84.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P="${PN}-2.8"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK for SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples ipv6 libressl gnutls +ssl"
+
+RDEPEND="
+ sys-libs/zlib
+ gnutls? ( net-libs/gnutls )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl )
+ )
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+"
+
+PATCHES=(
+ # Fix Pre-ISO headers
+ "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ # enable shared libs https://bugs.gentoo.org/583398
+ "${FILESDIR}/${PN}-2.8.70-shared_libs.patch"
+
+ # Fix parallel make
+ "${FILESDIR}/${PN}-2.8.70-parallel.patch"
+)
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ # Don't include xlocale.h as it got removed in >=glibc-2.26
+ --disable-xlocale
+ $(use_enable debug)
+ $(use_enable examples samples)
+ $(usex gnutls --enable-gnutls '')
+ $(usex ipv6 --enable-ipv6 '')
+ $(usex ssl '' --disable-ssl)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ docinto html
+ dodoc changelog.md
+
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+
+ if use examples; then
+ rm -r gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o || die
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ docinto html
+ dodoc -r gsoap/doc/*
+ fi
+}