summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-09 19:49:24 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-09 19:49:24 +0100
commit481e4782929aef758ba3de9d28cc598d88a1fe9c (patch)
treee8a8038f258c664193b25a88bf1cd3c326ef7373 /net-libs
parentdev-python/oslo-utils: cleanup (diff)
downloadgentoo-481e4782929aef758ba3de9d28cc598d88a1fe9c.tar.gz
gentoo-481e4782929aef758ba3de9d28cc598d88a1fe9c.tar.bz2
gentoo-481e4782929aef758ba3de9d28cc598d88a1fe9c.zip
net-libs/udns: Port to EAPI 7
Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/udns/metadata.xml14
-rw-r--r--net-libs/udns/udns-0.4.ebuild26
2 files changed, 15 insertions, 25 deletions
diff --git a/net-libs/udns/metadata.xml b/net-libs/udns/metadata.xml
index f0db182dbd42..63f962261674 100644
--- a/net-libs/udns/metadata.xml
+++ b/net-libs/udns/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
-<use>
- <flag name="tools">Build and install dnsget, ex-rdns and rblcheck tools</flag>
-</use>
-<longdescription>
-UDNS is a stub DNS resolver library with ability to perform both syncronous and asyncronous DNS queries.
-</longdescription>
+ <!-- maintainer-needed -->
+ <use>
+ <flag name="tools">Build and install dnsget, ex-rdns and rblcheck tools</flag>
+ </use>
+ <longdescription>
+ UDNS is a stub DNS resolver library with ability to perform both syncronous and asyncronous DNS queries.
+ </longdescription>
</pkgmetadata>
diff --git a/net-libs/udns/udns-0.4.ebuild b/net-libs/udns/udns-0.4.ebuild
index f19b2595dc0b..0953628925ed 100644
--- a/net-libs/udns/udns-0.4.ebuild
+++ b/net-libs/udns/udns-0.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
-inherit eutils multilib toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Async-capable DNS stub resolver library"
HOMEPAGE="http://www.corpit.ru/mjt/udns.html"
@@ -14,26 +14,18 @@ SLOT="0"
KEYWORDS="amd64 ~hppa ppc ~ppc64 sparc x86"
IUSE="ipv6 static +tools"
-# Yes, this doesn't depend on any other library beside "system" set
-DEPEND=""
-RDEPEND=""
-
src_configure() {
# Uses non-standard configure script, econf doesn't work
CC=$(tc-getCC) ./configure $(use_enable ipv6) || die "Configure failed"
}
src_compile() {
- if use tools; then
- emake shared
- else
- emake sharedlib
- fi
+ emake $(usex tools shared sharedlib)
}
src_install() {
dolib.so libudns.so.0
- dosym libudns.so.0 "/usr/$(get_libdir)/libudns.so"
+ dosym libudns.so.0 /usr/$(get_libdir)/libudns.so
if use tools; then
newbin dnsget_s dnsget
@@ -41,12 +33,10 @@ src_install() {
newbin rblcheck_s rblcheck
fi
- insinto /usr/include
- doins udns.h
+ doheader udns.h
doman udns.3
- if use tools; then
- doman dnsget.1 rblcheck.1
- fi
+ use tools && doman dnsget.1 rblcheck.1
+
dodoc NEWS NOTES TODO
}