summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2015-10-12 18:27:28 -0400
committerZero_Chaos <zerochaos@gentoo.org>2015-10-12 18:28:01 -0400
commit4ee823569a6e626c666eda1e74ec967a28c4ca3a (patch)
treef46a613bd6957b18d774f98fd61ce4c0da5bbc21 /net-libs
parentwww-apps/postfixadmin: bup, has sec fixes too (diff)
downloadgentoo-4ee823569a6e626c666eda1e74ec967a28c4ca3a.tar.gz
gentoo-4ee823569a6e626c666eda1e74ec967a28c4ca3a.tar.bz2
gentoo-4ee823569a6e626c666eda1e74ec967a28c4ca3a.zip
net-wireless/ubertooth net-wireless/kismet-ubertooth net-libs/libbtbb: version bump
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libbtbb/Manifest1
-rw-r--r--net-libs/libbtbb/libbtbb-2015.10.1.ebuild133
2 files changed, 134 insertions, 0 deletions
diff --git a/net-libs/libbtbb/Manifest b/net-libs/libbtbb/Manifest
index 222fa65d64e7..952fe8d5c434 100644
--- a/net-libs/libbtbb/Manifest
+++ b/net-libs/libbtbb/Manifest
@@ -1,2 +1,3 @@
DIST libbtbb-2015-09-R2.tar.gz 222045 SHA256 35ce44636649163f0d9a4de5905f686470f54c79b408959760db8c8182853161 SHA512 e300ec09de34644a0cd2f4aba2fe0b03021aaa0b0fe5035022f1e698ff10867adfd84850d0d40e9c070fbd622efee1b614221c1f5b1818f1d4f5d58cc3f31919 WHIRLPOOL 99d8c621b263cd3cd82e423eabff21d4979b0407c31430aa26424d273c9e3ed802e68833e3a100588a46a9a2126a84d0be56e41c1b609ea2eed4a3d64203c995
+DIST libbtbb-2015-10-R1.tar.gz 221859 SHA256 95f493d379a53ec1134cfb36349cc9aac95d77260db4fdb557313b0dbb5c1d5a SHA512 550d793326cfb4d31ed00d46faf3521ccafc133614f866961ba6226dff41d3deda428b45f01178e0dea7925635a64e843f0510049408c3f299ad427f2c0832ac WHIRLPOOL 4ac8697150ff5215765a5331695bfc6d2967ff61a4fc89820dd8e3c72f52f51f3d5aff2b4f020de6c728cd368a295a90bbd0bb1cebb60d895c84d5219cc70e77
DIST libbtbb-2015.09.2-rename-plugins.patch.xz 15636 SHA256 391a51ef542deecbb680d7d14f1649e8190096bce38a38965bc00fe1e97ad038 SHA512 40af251835fae9031a28720bf15ec9a903eac5fc42f38a0edf234021861e3c64e3fb77c03675ac7623b6dae901988d28f3ef90d53ea9e2b62b2d692ca0bf2d2f WHIRLPOOL eb15206c66f6293d509affa855f186ccfbb32c9d745675217c1228e7d07c0ef587bd6f997f664c1141e9fa0f4c453faefed3b82982b4099b53b81ec233b2dfec
diff --git a/net-libs/libbtbb/libbtbb-2015.10.1.ebuild b/net-libs/libbtbb/libbtbb-2015.10.1.ebuild
new file mode 100644
index 000000000000..3d12be1e26ff
--- /dev/null
+++ b/net-libs/libbtbb/libbtbb-2015.10.1.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib cmake-utils
+
+DESCRIPTION="A library to decode Bluetooth baseband packets"
+HOMEPAGE="http://libbtbb.sourceforge.net/"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/greatscottgadgets/libbtbb.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ MY_PV=${PV/\./-}
+ MY_PV=${MY_PV/./-R}
+ S=${WORKDIR}/${PN}-${MY_PV}
+ SRC_URI="https://github.com/greatscottgadgets/${PN}/archive/${MY_PV}.tar.gz -> ${PN}-${MY_PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE="+pcap +wireshark-plugins"
+
+RDEPEND="
+ pcap? ( net-libs/libpcap )
+ wireshark-plugins? (
+ >=net-analyzer/wireshark-1.8.3-r1:=
+ !>net-analyzer/wireshark-1.98
+ )
+"
+DEPEND="${RDEPEND}
+ wireshark-plugins? ( dev-libs/glib
+ virtual/pkgconfig )"
+
+get_PV() { local pv=$(best_version $1); pv=${pv#$1-}; pv=${pv%-r*}; pv=${pv//_}; echo ${pv}; }
+
+which_plugins() {
+ if has_version '>=net-analyzer/wireshark-1.12.0'; then
+ plugins="btbb btbredr"
+ elif has_version '<net-analyzer/wireshark-1.12.0'; then
+ plugins="btbb btle btsm"
+ fi
+}
+
+src_prepare(){
+ CMAKE_USE_DIR="${S}"
+ BUILD_DIR="${S}"_build
+ cmake-utils_src_prepare
+
+ if use wireshark-plugins; then
+ which_plugins
+ for i in ${plugins}
+ do
+ sed -i 's#column_info#packet#' wireshark/plugins/${i}/cmake/FindWireshark.cmake || die
+ CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
+ BUILD_DIR="${WORKDIR}"/${i}_build
+ cmake-utils_src_prepare
+ done
+ fi
+}
+
+src_configure() {
+ CMAKE_USE_DIR="${S}"
+ BUILD_DIR="${S}"_build
+ local mycmakeargs=(
+ -DDISABLE_PYTHON=true
+ -DPACKAGE_MANAGER=true
+ $(cmake-utils_use pcap PCAPDUMP)
+ $(cmake-utils_use pcap USE_PCAP)
+ )
+ cmake-utils_src_configure
+
+ if use wireshark-plugins; then
+ for i in ${plugins}
+ do
+ CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
+ BUILD_DIR="${WORKDIR}"/${i}_build
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)"
+ )
+ cmake-utils_src_configure
+ done
+ fi
+}
+
+src_compile(){
+ CMAKE_USE_DIR="${S}"
+ BUILD_DIR="${S}"_build
+ cmake-utils_src_compile
+
+ if use wireshark-plugins; then
+ for i in ${plugins}
+ do
+ CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
+ BUILD_DIR="${WORKDIR}"/${i}_build
+ cmake-utils_src_compile
+ done
+ fi
+}
+
+src_test(){
+ CMAKE_USE_DIR="${S}"
+ BUILD_DIR="${S}"_build
+ cmake-utils_src_test
+
+ if use wireshark-plugins; then
+ for i in ${plugins}
+ do
+ CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
+ BUILD_DIR="${WORKDIR}"/${i}_build
+ cmake-utils_src_test
+ done
+ fi
+}
+
+src_install(){
+ CMAKE_USE_DIR="${S}"
+ BUILD_DIR="${S}"_build
+ cmake-utils_src_install
+
+ if use wireshark-plugins; then
+ for i in ${plugins}
+ do
+ CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
+ BUILD_DIR="${WORKDIR}"/${i}_build
+ cmake-utils_src_install
+ done
+ fi
+}