summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-11-30 09:19:36 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-11-30 09:19:36 -0500
commit5782a5a70f3c7a93055fb43ecced4243c1090a9a (patch)
tree99d70b3852fdedeb67dc01456bb05a0c7626bcd8 /net-libs
parentmedia-plugins/vdr-dvbhddevice: fix HOMEPAGE and SRC_URI (diff)
downloadgentoo-5782a5a70f3c7a93055fb43ecced4243c1090a9a.tar.gz
gentoo-5782a5a70f3c7a93055fb43ecced4243c1090a9a.tar.bz2
gentoo-5782a5a70f3c7a93055fb43ecced4243c1090a9a.zip
net-libs/libmicrohttpd: version bump to 0.9.61
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libmicrohttpd/Manifest1
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.61.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/net-libs/libmicrohttpd/Manifest b/net-libs/libmicrohttpd/Manifest
index ea7664278fe0..a8bd2e611e0b 100644
--- a/net-libs/libmicrohttpd/Manifest
+++ b/net-libs/libmicrohttpd/Manifest
@@ -4,3 +4,4 @@ DIST libmicrohttpd-0.9.57.tar.gz 1332713 BLAKE2B 52e46726b220229ae722b4b94478bcd
DIST libmicrohttpd-0.9.58.tar.gz 1333687 BLAKE2B ef3dfb4684f2c387399d9044eb46de70c387b89bc4600529a9cdad7f2f31a25e0b0996b91d03cf42421979279781161b72d35eeb94d4bb101dd4d73bb6181bb7 SHA512 f68268bb0a0776ac0654a682fc598f4778561c2cc775e7315505c0e2f26f0633590d01f157984d348fdcedfb63d31d39add760a4ddb041694330015293d161b6
DIST libmicrohttpd-0.9.59.tar.gz 1396234 BLAKE2B 9cb2d52dd39bdc6c54267751e21a224ffa926f4200b392a28009c6f717b5059580884f4de1bb272f49f7c48bdae276df2832b413cc60db77222b7b1278ba6004 SHA512 2c9080ebd520631b5ab6eed42770c7911079365c7bc79ea74fc5502ebc370fdaea9a84a4d9db7cbd8ba1c4797c7531e127e3b73ad8d38601d700529f2bab84d5
DIST libmicrohttpd-0.9.60.tar.gz 1818383 BLAKE2B 693da0a02e289000bb657d843cd577311e97ca4d8cd698d659410e669295314d429eb9679eedac98398420f3386c1fa6800c33b883481120ea199585412f8e83 SHA512 418afc302e93ac93141c2457c2bf03c6a1da4a16ff19aa655312f9953e1d0b132b0dd983fc36ccc703688b0acd68fc0900f5927efcada354a10078ba5e577325
+DIST libmicrohttpd-0.9.61.tar.gz 1823891 BLAKE2B d7704f36790b7f14e03a02b7fbc5eaaca5fc22702f1fadfc94f9fe05329505d5bf9422a1ff38daa1f33c82db3e1196a8db754227574cc2cb9441c08a50d65d72 SHA512 d409ca2164a55b0eab948a8a4a17e0d6547942039354f593b293a286a3cae247bd67d7de4ce0dd4f1a3f3684948250076f582a8086546eb72598a43d7f41a27d
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.61.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.61.ebuild
new file mode 100644
index 000000000000..2c54b305f529
--- /dev/null
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.61.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit multilib-minimal
+
+MY_P="${P/_/}"
+
+DESCRIPTION="Small C library to run an HTTP server as part of another application"
+HOMEPAGE="https://www.gnu.org/software/libmicrohttpd/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/12"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="epoll messages ssl static-libs test"
+
+RDEPEND="ssl? (
+ dev-libs/libgcrypt:0=
+ net-libs/gnutls
+ )"
+
+# We disable tests below because they're broken,
+# but if enabled, we'll need this.
+DEPEND="${RDEPEND}
+ test? (
+ ssl? ( net-misc/curl[ssl] )
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS NEWS README ChangeLog"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ --enable-bauth \
+ --enable-dauth \
+ --disable-examples \
+ --enable-postprocessor \
+ --disable-thread-names \
+ $(use_enable epoll) \
+ $(use_enable test curl) \
+ $(use_enable messages) \
+ $(use_enable ssl https) \
+ $(use_with ssl gnutls) \
+ $(use_enable static-libs static)
+}
+
+# tests are broken in the portage environment.
+src_test() {
+ :
+}
+
+multilib_src_install_all() {
+ default
+
+ use static-libs || find "${ED}" -name '*.la' -delete
+}