summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-06-08 16:32:38 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-06-08 16:41:27 +0300
commit6018bb93cc024c25626ba0fa86bd9521ec5a4ef2 (patch)
tree1b9de6660c9c034881108dcf4b25faf36dffe711 /net-libs
parentnet-libs/pacparser: enable python3.8 (diff)
downloadgentoo-6018bb93cc024c25626ba0fa86bd9521ec5a4ef2.tar.gz
gentoo-6018bb93cc024c25626ba0fa86bd9521ec5a4ef2.tar.bz2
gentoo-6018bb93cc024c25626ba0fa86bd9521ec5a4ef2.zip
net-libs/pacparser: remove old 1.3.7
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/pacparser/pacparser-1.3.7.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/net-libs/pacparser/pacparser-1.3.7.ebuild b/net-libs/pacparser/pacparser-1.3.7.ebuild
deleted file mode 100644
index f3f2162bb12b..000000000000
--- a/net-libs/pacparser/pacparser-1.3.7.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit eutils python-r1 toolchain-funcs
-
-DESCRIPTION="Library to parse proxy auto-config files"
-HOMEPAGE="http://pacparser.manugarg.com/"
-SRC_URI="https://github.com/pacparser/${PN}/releases/download/${PV}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0/1"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc python"
-
-DEPEND="python? ( ${PYTHON_DEPS} )"
-RDEPEND="${DEPEND}"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-# spidermonkey-1.7.0 is bundled
-# tested unbundling with spidermonkey-1.8* and 1.7
-# and got many failures : unbundling not worth.
-
-src_prepare() {
- default
- sed -e 's|CFLAGS = |CFLAGS := $(CFLAGS) |' \
- -e 's|= $(PREFIX)|:= $(PREFIX)|g' \
- -e "s|share/doc.*pacparser|share/doc/${PF}|g" \
- -e "s|/lib|/$(get_libdir)|g" \
- -i src/Makefile || die
- export NO_INTERNET=yes
- tc-export CC AR RANLIB
-}
-
-src_compile() {
- emake -C src spidermonkey/js/src
- sed -e '/CC = gcc/d' \
- -i src/spidermonkey/js/src/config/Linux_All.mk || die
- emake -j1 -C src
- use python && python_foreach_impl emake -C src pymod
-}
-
-src_test() {
- emake -C src testpactester
-}
-
-src_install() {
- emake DESTDIR="${ED}" LIB_PREFIX="${ED}/usr/$(get_libdir)" -C src install
- dodoc README.md
- use python && python_foreach_impl \
- emake DESTDIR="${D}" \
- LIB_PREFIX="${D}/usr/$(get_libdir)" -C src install-pymod
- if use doc; then
- docompress -x /usr/share/doc/${PF}/{html,examples}
- else
- rm -r "${ED}"/usr/share/doc/${PF}/{html,examples} || die
- fi
-}