summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-06-12 10:07:45 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-06-12 10:47:38 +0200
commit7a952f587b48ac39e03773d8146530960d5864ca (patch)
tree31db1df163c2bca8eedf0b132f86672ab04b506d /net-libs
parentnet-libs/nghttp2: Removed old. (diff)
downloadgentoo-7a952f587b48ac39e03773d8146530960d5864ca.tar.gz
gentoo-7a952f587b48ac39e03773d8146530960d5864ca.tar.bz2
gentoo-7a952f587b48ac39e03773d8146530960d5864ca.zip
net-libs/nghttp2: Minor adjustments
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nghttp2/nghttp2-1.39.1.ebuild13
-rw-r--r--net-libs/nghttp2/nghttp2-9999.ebuild2
2 files changed, 6 insertions, 9 deletions
diff --git a/net-libs/nghttp2/nghttp2-1.39.1.ebuild b/net-libs/nghttp2/nghttp2-1.39.1.ebuild
index 970e71d4a994..92ac11a357a6 100644
--- a/net-libs/nghttp2/nghttp2-1.39.1.ebuild
+++ b/net-libs/nghttp2/nghttp2-1.39.1.ebuild
@@ -5,14 +5,14 @@
EAPI=7
-inherit autotools multilib-minimal
+inherit multilib-minimal
if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/nghttp2/nghttp2.git"
- inherit git-r3
+ inherit autotools git-r3
else
SRC_URI="https://github.com/nghttp2/nghttp2/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
fi
DESCRIPTION="HTTP/2 C Library"
@@ -31,10 +31,7 @@ RDEPEND="
${SSL_DEPEND}
dev-libs/boost:=[${MULTILIB_USEDEP},threads]
)
- hpack-tools? (
- >=dev-libs/jansson-2.5
- >=net-libs/http-parser-2.9.1:=
- )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
jemalloc? ( dev-libs/jemalloc[${MULTILIB_USEDEP}] )
utils? (
${SSL_DEPEND}
@@ -49,7 +46,7 @@ DEPEND="${RDEPEND}
src_prepare() {
default
- eautoreconf
+ [[ ${PV} == 9999 ]] && eautoreconf
}
multilib_src_configure() {
diff --git a/net-libs/nghttp2/nghttp2-9999.ebuild b/net-libs/nghttp2/nghttp2-9999.ebuild
index 0950bfb1def2..92ac11a357a6 100644
--- a/net-libs/nghttp2/nghttp2-9999.ebuild
+++ b/net-libs/nghttp2/nghttp2-9999.ebuild
@@ -53,9 +53,9 @@ multilib_src_configure() {
local myeconfargs=(
--disable-examples
--disable-failmalloc
+ --disable-python-bindings
--disable-werror
--without-cython
- --disable-python-bindings
$(use_enable cxx asio-lib)
$(use_enable debug)
$(multilib_native_use_enable hpack-tools)