summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-11-25 07:35:42 +0100
committerJeroen Roovers <jer@gentoo.org>2017-11-25 07:36:23 +0100
commit9d80f6044384852dc2d72de7358b4a633c882cd3 (patch)
treecfab36a113abdeae36867cf34ecb6db16a15bc9e /net-libs
parentx11-wm/lumina: cleanups (diff)
downloadgentoo-9d80f6044384852dc2d72de7358b4a633c882cd3.tar.gz
gentoo-9d80f6044384852dc2d72de7358b4a633c882cd3.tar.bz2
gentoo-9d80f6044384852dc2d72de7358b4a633c882cd3.zip
net-libs/nodejs: Add USE=inspector (bug #638456 by Rodrigo Saboya).
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nodejs/metadata.xml1
-rw-r--r--net-libs/nodejs/nodejs-8.9.1-r1.ebuild8
-rw-r--r--net-libs/nodejs/nodejs-9.2.0-r1.ebuild8
3 files changed, 13 insertions, 4 deletions
diff --git a/net-libs/nodejs/metadata.xml b/net-libs/nodejs/metadata.xml
index 2950626d4ef6..d512ddee8e7b 100644
--- a/net-libs/nodejs/metadata.xml
+++ b/net-libs/nodejs/metadata.xml
@@ -6,6 +6,7 @@
<name>Patrick Lauer</name>
</maintainer>
<use>
+ <flag name="inspector">Enable V8 inspector</flag>
<flag name="npm">Enable NPM package manager</flag>
<flag name="snapshot">Enable snapshot creation for faster startup</flag>
<flag name="systemtap">Enable SystemTAP/DTrace tracing</flag>
diff --git a/net-libs/nodejs/nodejs-8.9.1-r1.ebuild b/net-libs/nodejs/nodejs-8.9.1-r1.ebuild
index c36cfdcd86b5..e3f1fec1f463 100644
--- a/net-libs/nodejs/nodejs-8.9.1-r1.ebuild
+++ b/net-libs/nodejs/nodejs-8.9.1-r1.ebuild
@@ -16,7 +16,11 @@ SRC_URI="https://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz"
LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos"
-IUSE="cpu_flags_x86_sse2 debug doc icu +npm +snapshot +ssl systemtap test"
+IUSE="cpu_flags_x86_sse2 debug doc icu inspector +npm +snapshot +ssl systemtap test"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ inspector? ( icu ssl )
+"
RDEPEND="
>=dev-libs/libuv-1.15.0:=
@@ -33,7 +37,6 @@ DEPEND="${RDEPEND}
test? ( net-misc/curl )"
S="${WORKDIR}/node-v${PV}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
PATCHES=(
"${FILESDIR}"/gentoo-global-npm-config.patch
@@ -94,6 +97,7 @@ src_configure() {
local myconf=( --shared-http-parser --shared-libuv --shared-nghttp2 --shared-zlib )
use debug && myconf+=( --debug )
use icu && myconf+=( --with-intl=system-icu ) || myconf+=( --with-intl=none )
+ use inspector || myconf+=( --without-inspector )
use npm || myconf+=( --without-npm )
use snapshot && myconf+=( --with-snapshot )
use ssl && myconf+=( --shared-openssl ) || myconf+=( --without-ssl )
diff --git a/net-libs/nodejs/nodejs-9.2.0-r1.ebuild b/net-libs/nodejs/nodejs-9.2.0-r1.ebuild
index 741c961bd19c..782c12252046 100644
--- a/net-libs/nodejs/nodejs-9.2.0-r1.ebuild
+++ b/net-libs/nodejs/nodejs-9.2.0-r1.ebuild
@@ -16,7 +16,11 @@ SRC_URI="https://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz"
LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos"
-IUSE="cpu_flags_x86_sse2 debug doc icu +npm +snapshot +ssl systemtap test"
+IUSE="cpu_flags_x86_sse2 debug doc icu inspector +npm +snapshot +ssl systemtap test"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ inspector? ( icu ssl )
+"
RDEPEND="
>=dev-libs/libuv-1.16.1:=
@@ -33,7 +37,6 @@ DEPEND="${RDEPEND}
test? ( net-misc/curl )"
S="${WORKDIR}/node-v${PV}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
PATCHES=(
"${FILESDIR}"/gentoo-global-npm-config.patch
@@ -94,6 +97,7 @@ src_configure() {
local myconf=( --shared-http-parser --shared-libuv --shared-nghttp2 --shared-zlib )
use debug && myconf+=( --debug )
use icu && myconf+=( --with-intl=system-icu ) || myconf+=( --with-intl=none )
+ use inspector || myconf+=( --without-inspector )
use npm || myconf+=( --without-npm )
use snapshot && myconf+=( --with-snapshot )
use ssl && myconf+=( --shared-openssl ) || myconf+=( --without-ssl )