summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-07-17 21:54:15 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-07-18 16:09:36 +0000
commitc6a0dadddff0534c16a526b828b5670ba762a6c5 (patch)
tree951fa7c3c7d43fcd3a5c9fa91a0326647e64b9a8 /net-libs
parentapp-i18n/kimera: add support for app-i18n/imsettings (diff)
downloadgentoo-c6a0dadddff0534c16a526b828b5670ba762a6c5.tar.gz
gentoo-c6a0dadddff0534c16a526b828b5670ba762a6c5.tar.bz2
gentoo-c6a0dadddff0534c16a526b828b5670ba762a6c5.zip
net-libs/pacparser: version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/pacparser/Manifest1
-rw-r--r--net-libs/pacparser/metadata.xml1
-rw-r--r--net-libs/pacparser/pacparser-1.3.7.ebuild61
3 files changed, 62 insertions, 1 deletions
diff --git a/net-libs/pacparser/Manifest b/net-libs/pacparser/Manifest
index 7eb5deafff1a..91ab5be6434d 100644
--- a/net-libs/pacparser/Manifest
+++ b/net-libs/pacparser/Manifest
@@ -1 +1,2 @@
DIST pacparser-1.3.1.tar.gz 1229362 SHA256 040fb94c420f6aaad295b0b60cf1659f996fee1997c332bec2a6390955276585 SHA512 20295667d92eb5385429c085c14ca8dc1ba216487ff474304433f99119216934be2dd1647452173418de31f5345679dd7159eafd331e40a2b87564f878d31349 WHIRLPOOL 47caf428b4574d9fbb40cffe46afb38cc6bb786382805754f1653e3d554af60e695e1718902c94822b229b7fb4f9748257745a1b3faedfa02cc7b06ba457768f
+DIST pacparser-1.3.7.tar.gz 905596 SHA256 eb48ec2fc202d12a4b882133048c7590329849f32c2285bc4dbe418f29aad249 SHA512 979238204cd352ecf502a5a6216a35d7c47e82a173c32c6f0a5166f1fe790c66ac74ec1d9d0a58b54038d19e893f8b365ed868664f84ab9d5e653584bf20130b WHIRLPOOL be594e02c2eb41edf737ebd0a1b24c4aa044df9883f749f2d625858b16b7d15bd35045c481717c08ec65ec7043c09ef31d2a16d0c4bae6b1c78ab5fa86418c3e
diff --git a/net-libs/pacparser/metadata.xml b/net-libs/pacparser/metadata.xml
index afeebf32afe0..f15997fe5b71 100644
--- a/net-libs/pacparser/metadata.xml
+++ b/net-libs/pacparser/metadata.xml
@@ -21,7 +21,6 @@
supported right now).
</longdescription>
<upstream>
- <remote-id type="google-code">pacproxy</remote-id>
<remote-id type="github">pacparser/pacparser</remote-id>
</upstream>
</pkgmetadata>
diff --git a/net-libs/pacparser/pacparser-1.3.7.ebuild b/net-libs/pacparser/pacparser-1.3.7.ebuild
new file mode 100644
index 000000000000..08330b53c6a7
--- /dev/null
+++ b/net-libs/pacparser/pacparser-1.3.7.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit eutils python-r1 toolchain-funcs
+
+DESCRIPTION="Library to parse proxy auto-config files"
+HOMEPAGE="http://pacparser.manugarg.com/"
+SRC_URI="https://github.com/pacparser/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc python"
+
+DEPEND="python? ( ${PYTHON_DEPS} )"
+RDEPEND="${DEPEND}"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# spidermonkey-1.7.0 is bundled
+# tested unbundling with spidermonkey-1.8* and 1.7
+# and got many failures : unbundling not worth.
+
+src_prepare() {
+ default
+ sed -e 's|CFLAGS = |CFLAGS := $(CFLAGS) |' \
+ -e 's|= $(PREFIX)|:= $(PREFIX)|g' \
+ -e "s|share/doc.*pacparser|share/doc/${PF}|g" \
+ -e "s|/lib|/$(get_libdir)|g" \
+ -i src/Makefile || die
+ export NO_INTERNET=yes
+ tc-export CC AR RANLIB
+}
+
+src_compile() {
+ emake -C src spidermonkey/js/src
+ sed -e '/CC = gcc/d' \
+ -i src/spidermonkey/js/src/config/Linux_All.mk || die
+ emake -C src
+ use python && python_foreach_impl emake -C src pymod
+}
+
+src_test() {
+ emake -C src testpactester
+}
+
+src_install() {
+ emake DESTDIR="${ED}" LIB_PREFIX="${ED}/usr/$(get_libdir)" -C src install
+ dodoc README.md
+ use python && python_foreach_impl \
+ emake DESTDIR="${D}" \
+ LIB_PREFIX="${D}/usr/$(get_libdir)" -C src install-pymod
+ if use doc; then
+ docompress -x /usr/share/doc/${PF}/{html,examples}
+ else
+ rm -r "${ED}"/usr/share/doc/${PF}/{html,examples} || die
+ fi
+}