summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-09 19:49:36 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-09 19:49:36 +0100
commitf01c3a1606d40331738dde1fa5ca75d17b09cfb6 (patch)
tree425f2ebeb68c5632b4b5308d442db7a125de7db5 /net-libs
parentnet-libs/libnatpmp: Port to EAPI 7 (diff)
downloadgentoo-f01c3a1606d40331738dde1fa5ca75d17b09cfb6.tar.gz
gentoo-f01c3a1606d40331738dde1fa5ca75d17b09cfb6.tar.bz2
gentoo-f01c3a1606d40331738dde1fa5ca75d17b09cfb6.zip
net-libs/meanwhile: Port to EAPI 7
Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/meanwhile/files/meanwhile-1.0.2-gentoo-fhs-samples.patch26
-rw-r--r--net-libs/meanwhile/meanwhile-1.0.2-r1.ebuild50
2 files changed, 55 insertions, 21 deletions
diff --git a/net-libs/meanwhile/files/meanwhile-1.0.2-gentoo-fhs-samples.patch b/net-libs/meanwhile/files/meanwhile-1.0.2-gentoo-fhs-samples.patch
new file mode 100644
index 000000000000..d0bfc20fa76b
--- /dev/null
+++ b/net-libs/meanwhile/files/meanwhile-1.0.2-gentoo-fhs-samples.patch
@@ -0,0 +1,26 @@
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -5,10 +5,10 @@
+ if ENABLE_DOXYGEN
+
+ htmldoc_DATA = html/*
+-htmldocdir = $(datadir)/doc/@PACKAGE@-doc-@VERSION@/html
++htmldocdir = $(htmldir)
+
+ latexdoc_DATA = latex/*
+-latexdocdir = $(datadir)/doc/@PACKAGE@-doc-@VERSION@/latex
++latexdocdir = $(docdir)/latex
+
+ docdata = $(htmldoc_DATA) $(latexdoc_DATA)
+
+--- a/samples/Makefile.am
++++ b/samples/Makefile.am
+@@ -19,7 +19,7 @@
+ $(SAMPLES_SRC)
+
+
+-sampledir = $(datadir)/doc/@PACKAGE@-doc-@VERSION@/samples
++sampledir = $(docdir)/samples
+
+
+ EXTRA_DIST = $(sample_DATA) $(sample_SCRIPTS)
diff --git a/net-libs/meanwhile/meanwhile-1.0.2-r1.ebuild b/net-libs/meanwhile/meanwhile-1.0.2-r1.ebuild
index 7a2a8a624595..7d3f38645197 100644
--- a/net-libs/meanwhile/meanwhile-1.0.2-r1.ebuild
+++ b/net-libs/meanwhile/meanwhile-1.0.2-r1.ebuild
@@ -1,45 +1,53 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit eutils flag-o-matic
+EAPI=7
+
+inherit autotools flag-o-matic
DESCRIPTION="Meanwhile (Sametime protocol) library"
HOMEPAGE="http://meanwhile.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="LGPL-2"
-IUSE="doc debug"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 sparc x86"
+IUSE="doc debug"
-RDEPEND=">=dev-libs/glib-2:2"
-
-DEPEND="${RDEPEND}
- dev-libs/gmp
+RDEPEND="dev-libs/glib:2"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/gmp"
+BDEPEND="
virtual/pkgconfig
doc? ( app-doc/doxygen )"
-src_prepare(){
- epatch "${FILESDIR}/${P}-presence.patch" #239144
- epatch "${FILESDIR}/${P}-glib2.31.patch" #409081
-
- #241298
- sed -i -e "/sampledir/ s:-doc::" samples/Makefile.in || die
+PATCHES=(
+ # bug 239144
+ "${FILESDIR}"/${P}-presence.patch
+ # bug 409081
+ "${FILESDIR}"/${P}-glib2.31.patch
+ # bug 241298
+ "${FILESDIR}"/${P}-gentoo-fhs-samples.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
}
src_configure() {
- append-flags "-fno-tree-vrp"
- local myconf
- use doc || myconf="${myconf} --enable-doxygen=no"
+ append-cflags -fno-tree-vrp
- econf ${myconf} \
+ econf \
--disable-static \
+ --enable-doxygen=$(usex doc) \
$(use_enable debug)
}
src_install() {
- emake DESTDIR="${D}" install
- find "${D}" -name '*.la' -exec rm -f {} + || die "la file removal failed"
- dodoc AUTHORS ChangeLog NEWS README TODO
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}