summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-10 13:46:44 +0000
committerSam James <sam@gentoo.org>2023-03-10 13:55:11 +0000
commitfc1bf85e5fdc6beac9a1e701254b1442221ad91a (patch)
tree128623b906cec3799ef8a217613e5fc0af286994 /net-libs
parentnet-analyzer/fprobe: fix configure w/ clang 16 (diff)
downloadgentoo-fc1bf85e5fdc6beac9a1e701254b1442221ad91a.tar.gz
gentoo-fc1bf85e5fdc6beac9a1e701254b1442221ad91a.tar.bz2
gentoo-fc1bf85e5fdc6beac9a1e701254b1442221ad91a.zip
net-libs/libtorrent: fix configure w/ clang 16
Closes: https://bugs.gentoo.org/899566 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libtorrent/files/libtorrent-0.13.8-configure-clang-16.patch22
-rw-r--r--net-libs/libtorrent/libtorrent-0.13.8-r3.ebuild (renamed from net-libs/libtorrent/libtorrent-0.13.8-r2.ebuild)7
2 files changed, 27 insertions, 2 deletions
diff --git a/net-libs/libtorrent/files/libtorrent-0.13.8-configure-clang-16.patch b/net-libs/libtorrent/files/libtorrent-0.13.8-configure-clang-16.patch
new file mode 100644
index 000000000000..0a23141a7e58
--- /dev/null
+++ b/net-libs/libtorrent/files/libtorrent-0.13.8-configure-clang-16.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/899566
+https://github.com/rakshasa/libtorrent/pull/237
+
+From e851a8657d2ef5c332260f1e3a3896f438dba255 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Tue, 3 Jan 2023 14:41:11 +0100
+Subject: [PATCH] configure: Define _GNU_SOURCE when checking for
+ pthread_setname_np
+
+Previously, the test would always fail with compilers that do not
+support implicit function declarations because the pthread_setname_np
+function was not declared.
+--- a/scripts/checks.m4
++++ b/scripts/checks.m4
+@@ -469,6 +469,7 @@ AC_DEFUN([TORRENT_CHECK_PTHREAD_SETNAME_NP], [
+ AC_MSG_CHECKING(for pthread_setname_np type)
+
+ AC_TRY_LINK([
++ #define _GNU_SOURCE
+ #include <pthread.h>
+ #include <sys/types.h>
+ ],[
diff --git a/net-libs/libtorrent/libtorrent-0.13.8-r2.ebuild b/net-libs/libtorrent/libtorrent-0.13.8-r3.ebuild
index 5bb36208d46b..16ec5d67b750 100644
--- a/net-libs/libtorrent/libtorrent-0.13.8-r2.ebuild
+++ b/net-libs/libtorrent/libtorrent-0.13.8-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -26,7 +26,10 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
-PATCHES=( "${FILESDIR}"/${PN}-0.13.8-sysroot.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.13.8-sysroot.patch
+ "${FILESDIR}"/${PN}-0.13.8-configure-clang-16.patch
+)
src_prepare() {
default