summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/altermime/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/altermime/files')
-rw-r--r--net-mail/altermime/files/altermime-0.3.10-MIME_headers-overflow.patch13
-rw-r--r--net-mail/altermime/files/altermime-0.3.10-fprintf-fixes.patch46
-rw-r--r--net-mail/altermime/files/altermime-0.3.10-respect-flags.patch12
-rw-r--r--net-mail/altermime/files/altermime-0.3.11-respect-flags.patch20
4 files changed, 91 insertions, 0 deletions
diff --git a/net-mail/altermime/files/altermime-0.3.10-MIME_headers-overflow.patch b/net-mail/altermime/files/altermime-0.3.10-MIME_headers-overflow.patch
new file mode 100644
index 000000000000..bca39afba7f2
--- /dev/null
+++ b/net-mail/altermime/files/altermime-0.3.10-MIME_headers-overflow.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/320785
+
+--- MIME_headers.c
++++ MIME_headers.c
+@@ -2243,7 +2243,7 @@
+ {
+ if (MIMEH_DNORMAL) LOGGER_log("%s:%d:MIME_parse_contentlocation:DEBUG: filename = %s\n", FL, p);
+ snprintf(hinfo->name, sizeof(hinfo->name),"%s",p);
+- snprintf(hinfo->filename, sizeof(hinfo->name),"%s",p);
++ snprintf(hinfo->filename, sizeof(hinfo->filename),"%s",p);
+ FNFILTER_filter(hinfo->filename, _MIMEH_FILENAMELEN_MAX);
+ SS_push(&(hinfo->ss_filenames), hinfo->filename, strlen(hinfo->filename));
+
diff --git a/net-mail/altermime/files/altermime-0.3.10-fprintf-fixes.patch b/net-mail/altermime/files/altermime-0.3.10-fprintf-fixes.patch
new file mode 100644
index 000000000000..74d32f375a6e
--- /dev/null
+++ b/net-mail/altermime/files/altermime-0.3.10-fprintf-fixes.patch
@@ -0,0 +1,46 @@
+diff -urp altermime-0.3.10.orig/qpe.c altermime-0.3.10/qpe.c
+--- altermime-0.3.10.orig/qpe.c 2010-04-30 23:11:15.564697415 +0100
++++ altermime-0.3.10/qpe.c 2010-04-30 23:17:22.368691711 +0100
+@@ -97,7 +97,7 @@ int qp_encode( char *out, size_t out_siz
+ op+= strlen(paragraph);// +3; /** jump the output + =\r\n **/
+ out_remaining-= (strlen(paragraph)); // Was +3, updated to fix Outlook problems
+
+- QPD fprintf(stdout, "Soft break (%d + %d > 76 char) for '%s'\n", current_line_length, charout_size, paragraph);
++ QPD fprintf(stdout, "Soft break (%lu + %d > 76 char) for '%s'\n", (unsigned long)current_line_length, charout_size, paragraph);
+
+ /** reinitialize the paragraph **/
+ paragraph[0] = '\0';
+@@ -108,7 +108,7 @@ int qp_encode( char *out, size_t out_siz
+ }
+
+ snprintf(pp, pp_remaining, "%s", charout);
+- QPD fprintf(stdout,"charout='%s', size=%d, pp_remain=%d result='%s'\n", charout, charout_size, pp_remaining, paragraph);
++ QPD fprintf(stdout,"charout='%s', size=%d, pp_remain=%lu result='%s'\n", charout, charout_size, (unsigned long)pp_remaining, paragraph);
+ pp += charout_size;
+ pp_remaining -= charout_size;
+ p++;
+@@ -149,13 +149,13 @@ int qp_encode_from_file( char *fname )
+ out_size = in_size *3;
+ in_buffer = malloc( sizeof(char) *in_size +1);
+ if (in_buffer == NULL) {
+- QPD fprintf(stdout,"Error allocating %d bytes for input buffer\n", in_size);
++ QPD fprintf(stdout,"Error allocating %lu bytes for input buffer\n", (unsigned long)in_size);
+ return -1;
+ }
+
+ out_buffer = malloc( sizeof(char) *out_size *3 +1);
+ if (in_buffer == NULL) {
+- QPD fprintf(stdout,"Error allocating %d bytes for output buffer\n", out_size);
++ QPD fprintf(stdout,"Error allocating %lu bytes for output buffer\n", (unsigned long)out_size);
+ return -1;
+ }
+
+@@ -169,7 +169,7 @@ int qp_encode_from_file( char *fname )
+ ** we segfault ;) **/
+ *(in_buffer +in_size) = '\0';
+
+- QPD fprintf(stdout,"file %s is loaded, size = %d\n", fname, in_size);
++ QPD fprintf(stdout,"file %s is loaded, size = %lu\n", fname, (unsigned long)in_size);
+
+ qp_encode( out_buffer, out_size, in_buffer, in_size );
+
diff --git a/net-mail/altermime/files/altermime-0.3.10-respect-flags.patch b/net-mail/altermime/files/altermime-0.3.10-respect-flags.patch
new file mode 100644
index 000000000000..243d49c11034
--- /dev/null
+++ b/net-mail/altermime/files/altermime-0.3.10-respect-flags.patch
@@ -0,0 +1,12 @@
+--- Makefile.orig 2008-11-16 08:45:45.000000000 +0000
++++ Makefile 2010-10-08 00:35:48.258944495 +0100
+@@ -11,3 +11,3 @@
+ ALTERMIME_OPTIONS=
+-CFLAGS=-Wall -Werror -g -I. -O2 $(ALTERMIME_OPTIONS)
++CFLAGS+=-Wall
+ OBJS= strstack.o mime_alter.o ffget.o pldstr.o filename-filters.o logger.o MIME_headers.o libmime-decoders.o boundary-stack.o qpe.o
+@@ -21,3 +21,3 @@
+ altermime: altermime.c ${OBJS}
+- ${CC} ${CFLAGS} altermime.c ${OBJS} -o altermime
++ ${CC} ${CFLAGS} ${LDFLAGS} altermime.c ${OBJS} -o altermime
+
diff --git a/net-mail/altermime/files/altermime-0.3.11-respect-flags.patch b/net-mail/altermime/files/altermime-0.3.11-respect-flags.patch
new file mode 100644
index 000000000000..9f114ca17491
--- /dev/null
+++ b/net-mail/altermime/files/altermime-0.3.11-respect-flags.patch
@@ -0,0 +1,20 @@
+--- altermime-0.3.11.orig/Makefile
++++ altermime-0.3.11/Makefile
+@@ -9,7 +9,7 @@
+ # opposite of a disclaimer.
+ ALTERMIME_OPTIONS=-DALTERMIME_PRETEXT
+ #ALTERMIME_OPTIONS=
+-CFLAGS=-Wall -Werror -g -I. -O2 $(ALTERMIME_OPTIONS)
++CFLAGS+=-Wall $(ALTERMIME_OPTIONS)
+ OBJS= strstack.o mime_alter.o ffget.o pldstr.o filename-filters.o logger.o MIME_headers.o libmime-decoders.o boundary-stack.o qpe.o
+
+
+@@ -19,7 +19,7 @@
+ all: altermime
+
+ altermime: altermime.c ${OBJS}
+- ${CC} ${CFLAGS} altermime.c ${OBJS} -o altermime
++ ${CC} ${CFLAGS} ${LDFLAGS} altermime.c ${OBJS} -o altermime
+
+
+ # Build Install