summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-11-09 21:07:45 -0500
committerAaron Bauman <bman@gentoo.org>2019-11-09 21:07:45 -0500
commit27c97baf660c9c63c948d91dc8760ea937e77b56 (patch)
tree1afb8546b33a6acd349e562f0531824a1975db1d /net-mail/altermime
parentmedia-gfx/sam2p: drop old EAPI (diff)
downloadgentoo-27c97baf660c9c63c948d91dc8760ea937e77b56.tar.gz
gentoo-27c97baf660c9c63c948d91dc8760ea937e77b56.tar.bz2
gentoo-27c97baf660c9c63c948d91dc8760ea937e77b56.zip
net-mail/altermime: bump EAPI and stuff
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'net-mail/altermime')
-rw-r--r--net-mail/altermime/altermime-0.3.11.ebuild22
-rw-r--r--net-mail/altermime/files/altermime-0.3.10-MIME_headers-overflow.patch4
-rw-r--r--net-mail/altermime/files/altermime-0.3.11-respect-flags.patch4
3 files changed, 16 insertions, 14 deletions
diff --git a/net-mail/altermime/altermime-0.3.11.ebuild b/net-mail/altermime/altermime-0.3.11.ebuild
index 9d8ff8c549ae..1e09d54ec526 100644
--- a/net-mail/altermime/altermime-0.3.11.ebuild
+++ b/net-mail/altermime/altermime-0.3.11.ebuild
@@ -1,22 +1,24 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit eutils toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION=" alterMIME is a small program which is used to alter your mime-encoded mailpacks"
-SRC_URI="http://www.pldaniels.com/altermime/${P}.tar.gz"
-HOMEPAGE="http://pldaniels.com/altermime/"
+HOMEPAGE="https://pldaniels.com/altermime/"
+SRC_URI="https://www.pldaniels.com/altermime/${P}.tar.gz"
+
+KEYWORDS="amd64 ppc x86"
LICENSE="Sendmail"
SLOT="0"
-KEYWORDS="amd64 ppc x86"
IUSE=""
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.3.10-MIME_headers-overflow.patch \
- "${FILESDIR}"/${P}-respect-flags.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.10-MIME_headers-overflow.patch
+ "${FILESDIR}"/${P}-respect-flags.patch
+)
src_compile() {
emake CC="$(tc-getCC)"
diff --git a/net-mail/altermime/files/altermime-0.3.10-MIME_headers-overflow.patch b/net-mail/altermime/files/altermime-0.3.10-MIME_headers-overflow.patch
index bca39afba7f2..8d169e4bcf71 100644
--- a/net-mail/altermime/files/altermime-0.3.10-MIME_headers-overflow.patch
+++ b/net-mail/altermime/files/altermime-0.3.10-MIME_headers-overflow.patch
@@ -1,7 +1,7 @@
http://bugs.gentoo.org/320785
---- MIME_headers.c
-+++ MIME_headers.c
+--- a/MIME_headers.c
++++ b/MIME_headers.c
@@ -2243,7 +2243,7 @@
{
if (MIMEH_DNORMAL) LOGGER_log("%s:%d:MIME_parse_contentlocation:DEBUG: filename = %s\n", FL, p);
diff --git a/net-mail/altermime/files/altermime-0.3.11-respect-flags.patch b/net-mail/altermime/files/altermime-0.3.11-respect-flags.patch
index 9f114ca17491..f870414a2f6d 100644
--- a/net-mail/altermime/files/altermime-0.3.11-respect-flags.patch
+++ b/net-mail/altermime/files/altermime-0.3.11-respect-flags.patch
@@ -1,5 +1,5 @@
---- altermime-0.3.11.orig/Makefile
-+++ altermime-0.3.11/Makefile
+--- a/Makefile
++++ b/Makefile
@@ -9,7 +9,7 @@
# opposite of a disclaimer.
ALTERMIME_OPTIONS=-DALTERMIME_PRETEXT