summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/archivemail
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/archivemail')
-rw-r--r--net-mail/archivemail/Manifest1
-rw-r--r--net-mail/archivemail/archivemail-0.9.0.ebuild42
-rw-r--r--net-mail/archivemail/files/0.7.2-empty_maildir-r266.patch15
-rw-r--r--net-mail/archivemail/metadata.xml8
4 files changed, 66 insertions, 0 deletions
diff --git a/net-mail/archivemail/Manifest b/net-mail/archivemail/Manifest
new file mode 100644
index 000000000000..c188368daee6
--- /dev/null
+++ b/net-mail/archivemail/Manifest
@@ -0,0 +1 @@
+DIST archivemail-0.9.0.tar.gz 63482 SHA256 4b430e2fba6f24970a67bd61eef39d7eae8209c7bef001196b997be1916fc663 SHA512 7c36108919be22f8cf71aea91435084495ceef54c251ede0aca9d981bb9c01119925d334c1d84eb2c53657170ac6bf0897fccd1f9df05c59fc46e1177194dfb2 WHIRLPOOL a004ef0a4b830afb4ea9cc2d2275d5272c332caf2db4c40f59ead13e190795a1238f899c385d9218a9858d725d7201e1cea92fa857a190482df9306c572e268f
diff --git a/net-mail/archivemail/archivemail-0.9.0.ebuild b/net-mail/archivemail/archivemail-0.9.0.ebuild
new file mode 100644
index 000000000000..65396a6635a2
--- /dev/null
+++ b/net-mail/archivemail/archivemail-0.9.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit distutils
+
+DESCRIPTION="Tool written in Python for archiving and compressing old email in mailboxes"
+HOMEPAGE="http://archivemail.sourceforge.net/"
+SRC_URI="mirror://sourceforge/archivemail/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 sparc x86"
+IUSE=""
+
+DOCS="examples/* FAQ"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ distutils_src_prepare
+ # Fix tests for python-2.7
+ sed -i -e 's:\(fp_archive = \)FixedGzipFile:\1gzip.GzipFile:' \
+ test_archivemail || die "sed failed"
+}
+
+src_test() {
+ echo ">>> Test phase: ${CATEGORY}/${PF}"
+ "${S}"/test_archivemail || die "test_archivemail failed"
+}
+
+src_install() {
+ distutils_src_install --install-data=/usr/share
+ mv "${D}/usr/share/share/man" "${D}/usr/share/" && \
+ rm -rf "${D}/usr/share/share" || die
+}
diff --git a/net-mail/archivemail/files/0.7.2-empty_maildir-r266.patch b/net-mail/archivemail/files/0.7.2-empty_maildir-r266.patch
new file mode 100644
index 000000000000..4af2366b7433
--- /dev/null
+++ b/net-mail/archivemail/files/0.7.2-empty_maildir-r266.patch
@@ -0,0 +1,15 @@
+http://archivemail.svn.sourceforge.net/viewvc/archivemail?view=rev&revision=266
+Fixed crash when archiving an empty maildir with python 2.5.
+The incompatible changes in mailbox.Maildir triggered an assertion in
+_archive_dir(); removing that assertion since it looks not useful anyway.
+
+--- trunk/archivemail 2008/03/15 15:59:05 265
++++ trunk/archivemail 2008/03/15 18:42:56 266
+@@ -1287,7 +1287,6 @@
+ original = mailbox.MHMailbox(mailbox_name)
+ else:
+ unexpected_error("unknown type: %s" % type)
+- assert(original)
+
+ cache = IdentityCache(mailbox_name)
+
diff --git a/net-mail/archivemail/metadata.xml b/net-mail/archivemail/metadata.xml
new file mode 100644
index 000000000000..729518bf2231
--- /dev/null
+++ b/net-mail/archivemail/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <upstream>
+ <remote-id type="sourceforge">archivemail</remote-id>
+ </upstream>
+</pkgmetadata>