summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-10-18 23:10:31 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-10-18 23:11:54 +0200
commit5dedd510e646e090a195a7151243b9095c413d9d (patch)
tree44fbf7ad59385b603a149716c082de9060612f94 /net-mail/courier-imap
parentprofiles: Drop mask for removed app-emacs/crypt++ (diff)
downloadgentoo-5dedd510e646e090a195a7151243b9095c413d9d.tar.gz
gentoo-5dedd510e646e090a195a7151243b9095c413d9d.tar.bz2
gentoo-5dedd510e646e090a195a7151243b9095c413d9d.zip
net-mail/courier-imap: add 5.2.5
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'net-mail/courier-imap')
-rw-r--r--net-mail/courier-imap/Manifest1
-rw-r--r--net-mail/courier-imap/courier-imap-5.2.5.ebuild229
2 files changed, 230 insertions, 0 deletions
diff --git a/net-mail/courier-imap/Manifest b/net-mail/courier-imap/Manifest
index 2dd66ee197e8..3cdd3d75fb5b 100644
--- a/net-mail/courier-imap/Manifest
+++ b/net-mail/courier-imap/Manifest
@@ -6,3 +6,4 @@ DIST courier-imap-5.1.8.tar.bz2 3395074 BLAKE2B 1d563d49d61f3ab89297afdc9dd29472
DIST courier-imap-5.2.1.tar.bz2 3411197 BLAKE2B 7b34b523f7c8df3127af6cc7d10ca0bc78638e60d0bc52871d762a4dc28e192b8b64dc1e1a0ee572f11afb4ebd889bfbe426e7520e43caef16d40bdf0224a4bf SHA512 88ce60b666bc1db10059ffd34f76d8275f399ac1833ee820308db25df49ab4914a03547e6d58075d5fecb34204b5fb958877db06b3bb4529eb8cb9e547bbcf63
DIST courier-imap-5.2.3.tar.bz2 3410307 BLAKE2B d6f9aa02c2367bca898a7322f55a6f178984b0828e16fd4755d221b02384068a54b99c336e3aa4ed247eb04663be041af81803cb27fe6bae6b2f57dfe445f919 SHA512 6df3c12aea6004875c3f1e8dce46b0f199b7e3c881acf79fe6df507022b5e9dcd0cc4ddef6a94bf8763746f4db58f47066731b1f969afcf5f51bed451116af4f
DIST courier-imap-5.2.4.tar.bz2 3411159 BLAKE2B a26b8b3a6893cfb83ba4d6fa24eb3ac391b200c9642618c48db09d37f40ba8e0409165a8c7b448ab22fe3dd32b613a1a7b5de96860f0e8854a5b037979ea4441 SHA512 db5a53f82b66b2ed99a66f13c97b041e6e275b3ea662b85ce19b0aa13dfeb4e60ec091d608992f52691e3514c3d3429f9249ce5322c5e247fc0058dfef92716b
+DIST courier-imap-5.2.5.tar.bz2 3411629 BLAKE2B 764ac51815777df53b3ce429a4f50ca70f4f2d8b1920f1332691f4ed951939099fa46c0a11301ee0cbcc2471f2f73b7c4dfd8fe5de9389e883552658cd73eea4 SHA512 f7864bc7c23ee08ab8c90b3d83e577c62c468f96b2481e909dc0eb5aab6c6ef141e164742458776dd1106e50d8752e6e8102971a4e3d75d6a108dd72fcae0de4
diff --git a/net-mail/courier-imap/courier-imap-5.2.5.ebuild b/net-mail/courier-imap/courier-imap-5.2.5.ebuild
new file mode 100644
index 000000000000..4a3263fa21b3
--- /dev/null
+++ b/net-mail/courier-imap/courier-imap-5.2.5.ebuild
@@ -0,0 +1,229 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit readme.gentoo-r1 systemd
+
+DESCRIPTION="An IMAP daemon designed specifically for maildirs"
+HOMEPAGE="https://www.courier-mta.org/imap/"
+SRC_URI="mirror://sourceforge/courier/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+IUSE="berkdb debug +gdbm gnutls ipv6 selinux trashquota"
+REQUIRED_USE="|| ( berkdb gdbm )"
+
+CDEPEND="
+ gnutls? ( net-libs/gnutls:=[tools] )
+ !gnutls? (
+ dev-libs/openssl:0=
+ )
+ net-libs/courier-authlib
+ net-libs/courier-unicode
+ net-mail/mailbase
+ net-dns/libidn:=
+ berkdb? ( sys-libs/db:= )
+ gdbm? ( sys-libs/gdbm:= )
+ !mail-mta/courier
+"
+DEPEND="${CDEPEND}
+ dev-lang/perl
+ sys-process/procps
+"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-courier )
+"
+
+RDEPEND="${RDEPEND}
+ !net-mail/cyrus-imapd
+ !net-mail/courier-common
+"
+
+RC_VER="4.0.6-r1"
+INITD_VER="4.0.6-r1"
+
+# make check is not supported by this package due to the
+# --enable-workarounds-for-imap-client-bugs option.
+RESTRICT="test"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+Please read http://www.courier-mta.org/imap/INSTALL.html#upgrading
+and remove TLS_DHPARAMS from configuration files or run mkdhparams
+
+For a quick-start howto please refer to
+${PN}-gentoo.readme in /usr/share/doc/${PF}
+
+Please convert maildir to utf8
+and rerun mkdhparams if needed. Location has changed
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-5.1.8-aclocal-fix.patch"
+ "${FILESDIR}/${PN}-5.0.8-ar-fix.patch"
+)
+
+src_configure() {
+ local myconf=""
+
+ # Default to gdbm if both berkdb and gdbm are present.
+ if use gdbm ; then
+ einfo "Building with GDBM support"
+ myconf="${myconf} --with-db=gdbm"
+ elif use berkdb ; then
+ einfo "Building with BerkeleyDB support"
+ myconf="${myconf} --with-db=db"
+ fi
+
+ if use trashquota ; then
+ einfo "Building with Trash Quota Support"
+ myconf="${myconf} --with-trashquota"
+ fi
+
+ econf \
+ --with-notice=unicode \
+ --disable-root-check \
+ --bindir=/usr/sbin \
+ --sysconfdir="/etc/${PN}" \
+ --libexecdir="/usr/$(get_libdir)/${PN}" \
+ --localstatedir="/var/lib/${PN}" \
+ --enable-workarounds-for-imap-client-bugs \
+ --with-mailuser=mail \
+ --with-mailgroup=mail \
+ --with-certsdir="/etc/courier-imap" \
+ $(use_with ipv6) \
+ $(use_with gnutls) \
+ ${myconf}
+}
+
+src_install() {
+ dodir "/var/lib/${PN}" /etc/pam.d
+ keepdir /var/lib/courier-imap
+
+ default
+ rm -r "${D}/etc/pam.d" || die
+
+ # Avoid name collisions in /usr/sbin wrt imapd and pop3d
+ for name in imapd pop3d ; do
+ mv "${D}/usr/sbin/"{,courier-}${name} \
+ || die "failed to rename ${name} to courier-${name}"
+ done
+
+ # Hack /usr/lib/courier-imap/foo.rc to use ${MAILDIR} instead of
+ # 'Maildir', and to use /usr/sbin/courier-foo names.
+ for service in {imapd,pop3d}{,-ssl} ; do
+ sed -e 's/Maildir/${MAILDIR}/' \
+ -i "${D}/usr/$(get_libdir)/${PN}/${service}.rc" \
+ || die "sed failed"
+ sed -e "s/\/usr\/sbin\/${service}/\/usr\/sbin\/courier-${service}/" \
+ -i "${D}/usr/$(get_libdir)/${PN}/${service}.rc" \
+ || die "sed failed"
+ done
+
+ # Rename the config files correctly and add a value for ${MAILDIR}
+ # to them.
+ for service in {imapd,pop3d}{,-ssl} ; do
+ mv "${D}/etc/${PN}/${service}"{.dist,} \
+ || die "failed to rename ${service}.dist to ${service}"
+ echo -e '\n# Hardwire a value for ${MAILDIR}' \
+ >> "${D}/etc/${PN}/${service}"
+ echo 'MAILDIR=.maildir' >> "${D}/etc/${PN}/${service}"
+ echo 'MAILDIRPATH=.maildir' >> "${D}/etc/${PN}/${service}"
+ done
+
+ for service in imapd pop3d ; do
+ echo -e '# Put any program for ${PRERUN} here' \
+ >> "${D}/etc/${PN}/${service}"
+ echo 'PRERUN=' >> "${D}/etc/${PN}/${service}"
+ echo -e '# Put any program for ${LOGINRUN} here' \
+ >> "${D}/etc/${PN}/${service}"
+ echo -e '# this is for relay-ctrl-allow in 4*' \
+ >> "${D}/etc/${PN}/${service}"
+ echo 'LOGINRUN=' >> "${D}/etc/${PN}/${service}"
+ done
+
+ for x in "${D}/usr/sbin"/* ; do
+ if [[ -L "${x}" ]] ; then
+ rm "${x}" || die "failed to remove ${x}"
+ fi
+ done
+
+ mv "${D}/usr/share"/* "${D}/usr/sbin/" || die
+ mv "${D}/usr/sbin/man" "${D}/usr/share/" || die
+
+ rm "${D}/usr/sbin/"{mkimapdcert,mkpop3dcert} || die
+
+ dosbin "${FILESDIR}/mkimapdcert" "${FILESDIR}/mkpop3dcert"
+
+ dosym ../../sbin/courierlogger "/usr/$(get_libdir)/${PN}/courierlogger"
+
+ for initd in courier-{imapd,pop3d}{,-ssl} ; do
+ sed -e "s:GENTOO_LIBDIR:$(get_libdir):g" \
+ "${FILESDIR}/${PN}-${INITD_VER}-${initd}.rc6" \
+ > "${T}/${initd}" \
+ || die "initd libdir-sed failed"
+ doinitd "${T}/${initd}"
+ done
+
+ cp "${FILESDIR}"/courier-*-r1.service .
+
+ sed -i \
+ -e "s:/usr/lib/:/usr/$(get_libdir)/:" \
+ courier-*-r1.service \
+ || die
+
+ systemd_newunit courier-authdaemond-r1.service \
+ courier-authdaemond.service
+ systemd_newunit courier-imapd-ssl-r1.service \
+ courier-imapd-ssl.service
+ systemd_newunit courier-imapd-r1.service \
+ courier-imapd.service
+
+ exeinto "/usr/$(get_libdir)/${PN}"
+ for exe in gentoo-{imapd,pop3d}{,-ssl}.rc courier-{imapd,pop3d}.indirect ; do
+ sed -e "s:GENTOO_LIBDIR:$(get_libdir):g" \
+ "${FILESDIR}/${PN}-${RC_VER}-${exe}" \
+ > "${T}/${exe}" \
+ || die "exe libdir-sed failed"
+ doexe "${T}/${exe}"
+ done
+
+ # Avoid a collision with mail-mta/netqmail, bug 482098.
+ mv "${D}/usr/sbin/"{,courier-}maildirmake \
+ || die "failed to rename maildirmake to courier-maildirmake"
+ mv "${D}/usr/share/man/man1/"{,courier-}maildirmake.1 \
+ || die "failed to rename maildirmake.1 to courier-maildirmake.1"
+
+ rm -rf "${D}"/usr/sbin/doc
+
+ dodoc AUTHORS INSTALL NEWS README ChangeLog
+ readme.gentoo_create_doc
+ dodoc "${FILESDIR}/${PN}-gentoo.readme"
+ docinto imap
+ dodoc libs/imap/ChangeLog libs/imap/BUGS* libs/imap/README*
+ docinto maildir
+ dodoc libs/maildir/AUTHORS libs/maildir/*.html libs/maildir/README*
+ docinto rfc2045
+ dodoc libs/rfc2045/*.html
+ docinto tcpd
+ dodoc libs/tcpd/README* libs/tcpd/*.html
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/${PN}.cron ${PN}
+}
+
+pkg_postinst() {
+ # Some users have been reporting that permissions on this directory were
+ # getting scrambled, so let's ensure that they are sane.
+ fperms 0755 "${ROOT}/usr/$(get_libdir)/${PN}"
+
+ readme.gentoo_print_elog
+
+ elog ""
+ elog "Courier Imap now run as user mail:mail."
+ elog ""
+ elog "This require you to enable read/write access to the caches:"
+ elog "/var/lib/courier-imap/courierssl*cache (chown mail:mail)"
+ elog "and read access to the certificates (e.g. /etc/courier-imap/pop3d.pem )"
+}