summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/cyrus-imap-admin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/cyrus-imap-admin')
-rw-r--r--net-mail/cyrus-imap-admin/Manifest2
-rw-r--r--net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.17-r1.ebuild73
-rw-r--r--net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.18.ebuild72
-rw-r--r--net-mail/cyrus-imap-admin/files/cyrus-imap-admin-2.4.10-ldflags.patch56
-rw-r--r--net-mail/cyrus-imap-admin/metadata.xml5
5 files changed, 208 insertions, 0 deletions
diff --git a/net-mail/cyrus-imap-admin/Manifest b/net-mail/cyrus-imap-admin/Manifest
new file mode 100644
index 000000000000..a9dbe57bc583
--- /dev/null
+++ b/net-mail/cyrus-imap-admin/Manifest
@@ -0,0 +1,2 @@
+DIST cyrus-imapd-2.4.17.tar.gz 2486355 SHA256 b3e30052c764ee7163947ffde27bdd58bd4dd2e5697ad144491941e46300a583 SHA512 86ffe1664ca3c3df164ed8fca21cc08ddae12380e1485deccec7da4ec263d8b953a806e05f0b10f6fb7717a0d40fc05669792b77cc66d7c5067061c8506e59ee WHIRLPOOL 22566578217a5901793b886ff020aa1deecbb81bf85f54a524b58de129029e51b0aa358db902a2139584d05f668404cb98ca2ff3fa33803ce986e07b95c69c45
+DIST cyrus-imapd-2.4.18.tar.gz 2495098 SHA256 166a0a1efbf01f71d9d8449569152b3cda4949cd689f299a5e77a38d7026012c SHA512 3b234c1773fe5d57cae35743985930bc7fed2eedaa0919598da8fb19588f95b3beb8ad166d3b4f0c96faf006ff56ed5027ec516fab6007edbe46c4f45572a1ef WHIRLPOOL 1a243a9b3875105dfc414e1092f328691b6bef7c0d04f8bd91824ca0d01c715ebc2449c37bbca2ab86193e4d2dc426b33cfd31a0cdfdea0bacc081fd9010b1df
diff --git a/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.17-r1.ebuild b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.17-r1.ebuild
new file mode 100644
index 000000000000..d9e0ad7f9e17
--- /dev/null
+++ b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.17-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools db-use eutils perl-app toolchain-funcs
+
+MY_PV=${PV/_/}
+
+DESCRIPTION="Utilities and Perl modules to administer a Cyrus IMAP server"
+HOMEPAGE="http://www.cyrusimap.org/"
+SRC_URI="ftp://ftp.cyrusimap.org/cyrus-imapd/cyrus-imapd-${MY_PV}.tar.gz"
+
+LICENSE="BSD-with-attribution"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ppc ppc64 sparc x86"
+IUSE="berkdb kerberos ssl"
+
+RDEPEND=">=dev-lang/perl-5.6.1
+ >=dev-libs/cyrus-sasl-2.1.13
+ dev-perl/Term-ReadLine-Perl
+ dev-perl/TermReadKey
+ berkdb? ( >=sys-libs/db-3.2 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ kerberos? ( virtual/krb5 )"
+
+DEPEND="$RDEPEND"
+
+S="${WORKDIR}/cyrus-imapd-${MY_PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.4.10-ldflags.patch"
+ sed -i -e "s/ar cr/$(tc-getAR) cr/" \
+ perl/sieve/lib/Makefile.in \
+ imap/Makefile.in \
+ lib/Makefile.in \
+ installsieve/Makefile.in \
+ com_err/et/Makefile.in \
+ sieve/Makefile.in \
+ syslog/Makefile.in
+ AT_M4DIR="cmulocal" eautoreconf
+}
+
+src_configure() {
+ local myconf
+ if use berkdb ; then
+ myconf="--with-bdb-incdir=$(db_includedir)"
+ fi
+ econf \
+ --disable-server \
+ --enable-murder \
+ --enable-netscapehack \
+ --with-cyrus-group=mail \
+ --with-com_err=yes \
+ --with-perl=/usr/bin/perl \
+ --without-krb \
+ --without-krbdes \
+ $(use_with berkdb bdb) \
+ $(use_enable kerberos gssapi) \
+ $(use_with ssl openssl) \
+ ${myconf}
+}
+
+src_compile() {
+ emake -C "${S}/lib" all
+ emake -C "${S}/perl" all
+}
+
+src_install () {
+ emake -C "${S}/perl" DESTDIR="${D}" INSTALLDIRS=vendor install
+ perl_delete_localpod # bug #98122
+}
diff --git a/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.18.ebuild b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.18.ebuild
new file mode 100644
index 000000000000..dd266689d633
--- /dev/null
+++ b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.18.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools db-use eutils perl-app toolchain-funcs
+
+MY_PV=${PV/_/}
+
+DESCRIPTION="Utilities and Perl modules to administer a Cyrus IMAP server"
+HOMEPAGE="http://www.cyrusimap.org/"
+SRC_URI="ftp://ftp.cyrusimap.org/cyrus-imapd/cyrus-imapd-${MY_PV}.tar.gz"
+
+LICENSE="BSD-with-attribution"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="berkdb kerberos ssl"
+
+RDEPEND=">=dev-lang/perl-5.6.1
+ >=dev-libs/cyrus-sasl-2.1.13
+ dev-perl/Term-ReadLine-Perl
+ dev-perl/TermReadKey
+ berkdb? ( >=sys-libs/db-3.2:* )
+ ssl? ( >=dev-libs/openssl-0.9.6:* )
+ kerberos? ( virtual/krb5 )"
+
+DEPEND="$RDEPEND"
+
+S="${WORKDIR}/cyrus-imapd-${MY_PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.4.10-ldflags.patch"
+ sed -i -e "s/ar cr/$(tc-getAR) cr/" \
+ perl/sieve/lib/Makefile.in \
+ imap/Makefile.in \
+ lib/Makefile.in \
+ installsieve/Makefile.in \
+ com_err/et/Makefile.in \
+ sieve/Makefile.in \
+ syslog/Makefile.in
+ AT_M4DIR="cmulocal" eautoreconf
+}
+
+src_configure() {
+ local myconf
+ if use berkdb ; then
+ myconf="--with-bdb-incdir=$(db_includedir)"
+ fi
+ econf \
+ --disable-server \
+ --enable-murder \
+ --enable-netscapehack \
+ --with-cyrus-group=mail \
+ --with-com_err=yes \
+ --with-perl=/usr/bin/perl \
+ --without-krb \
+ --without-krbdes \
+ $(use_with berkdb bdb) \
+ $(use_enable kerberos gssapi) \
+ $(use_with ssl openssl) \
+ ${myconf}
+}
+
+src_compile() {
+ emake -C "${S}/lib" all
+ emake -C "${S}/perl" all
+}
+
+src_install () {
+ emake -C "${S}/perl" DESTDIR="${D}" INSTALLDIRS=vendor install
+ perl_delete_localpod # bug #98122
+}
diff --git a/net-mail/cyrus-imap-admin/files/cyrus-imap-admin-2.4.10-ldflags.patch b/net-mail/cyrus-imap-admin/files/cyrus-imap-admin-2.4.10-ldflags.patch
new file mode 100644
index 000000000000..a05941408250
--- /dev/null
+++ b/net-mail/cyrus-imap-admin/files/cyrus-imap-admin-2.4.10-ldflags.patch
@@ -0,0 +1,56 @@
+--- perl/Makefile.in 2011-06-21 22:50:39.000000000 +0300
++++ perl/Makefile.in 2011-06-22 12:42:04.000000000 +0300
+@@ -74,6 +74,7 @@
+ cyrus_prefix = @cyrus_prefix@
+
+ CC = @CC@
++LDFLAGS = @LDFLAGS@
+ PLMAKE = imap/Makefile
+
+ all::
+@@ -83,6 +84,7 @@
+ if [ -f Makefile.PL -a ! -f Makefile ]; then \
+ LIB_RT="$(LIB_RT)" \
+ ZLIB="$(ZLIB)" \
++ LDDLFLAGS="-shared $(LDFLAGS)" \
+ BDB_LIB="$(BDB_LIB)" BDB_INC="$(BDB_INC)" \
+ OPENSSL_LIB="$(OPENSSL_LIB)" OPENSSL_INC="$(OPENSSL_INC)" \
+ SASL_LIB="$(SASL_LIB)" SASL_INC="$(SASL_INC)" CC="$(CC)" \
+--- perl/imap/Makefile.PL 2011-06-21 22:50:39.000000000 +0300
++++ perl/imap/Makefile.PL 2011-06-22 12:42:22.000000000 +0300
+@@ -53,6 +53,8 @@
+ my $LIB_RT = $ENV{LIB_RT};
+ my $ZLIB = $ENV{ZLIB};
+
++my $LDDLFLAGS = $ENV{LDDLFLAGS};
++
+ # See lib/ExtUtils/MakeMaker.pm for details of how to influence
+ # the contents of the Makefile that is written.
+ $libs = "-lcyrus";
+@@ -75,6 +77,7 @@
+ 'OBJECT' => 'IMAP.o',
+ 'MYEXTLIB' => '../../lib/libcyrus.a ../../lib/libcyrus_min.a',
+ 'LIBS' => ["$BDB_LIB $SASL_LIB $OPENSSL_LIB $LIB_RT $ZLIB -lssl -lcrypto"],
++ 'LDDLFLAGS' => "$LDDLFLAGS",
+ 'DEFINE' => '-DPERL_POLLUTE', # e.g., '-DHAVE_SOMETHING'
+ 'INC' => "-I../../lib -I../.. -I../../com_err/et $SASL_INC $OPENSSL_INC",
+ 'EXE_FILES' => [cyradm],
+--- perl/sieve/managesieve/Makefile.PL 2011-06-21 22:50:39.000000000 +0300
++++ perl/sieve/managesieve/Makefile.PL 2011-06-22 13:13:04.000000000 +0300
+@@ -53,6 +53,8 @@
+ my $LIB_RT = $ENV{LIB_RT};
+ my $ZLIB = $ENV{ZLIB};
+
++my $LDDLFLAGS = $ENV{LDFLAGS};
++
+ $libs = "-lcyrus";
+
+ # See lib/ExtUtils/MakeMaker.pm for details of how to influence
+@@ -63,6 +65,7 @@
+ 'VERSION_FROM' => 'managesieve.pm', # finds $VERSION
+ 'MYEXTLIB' => '../lib/isieve.o ../lib/lex.o ../lib/mystring.o ../lib/request.o ../../../lib/libcyrus.a ../../../lib/libcyrus_min.a',
+ 'LIBS' => ["$BDB_LIB $SASL_LIB $OPENSSL_LIB $LIB_RT $ZLIB -lssl -lcrypto"],
++ 'LDDLFLAGS' => "-shared $LDDLFLAGS",
+ 'DEFINE' => '-DPERL_POLLUTE', # e.g., '-DHAVE_SOMETHING'
+ 'INC' => "-I../lib/ -I../../../lib/ $SASL_INC $OPENSSL_INC",
+ );
diff --git a/net-mail/cyrus-imap-admin/metadata.xml b/net-mail/cyrus-imap-admin/metadata.xml
new file mode 100644
index 000000000000..51f94e3fbe0e
--- /dev/null
+++ b/net-mail/cyrus-imap-admin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-mail</herd>
+</pkgmetadata>