summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2019-06-25 10:27:39 -0400
committerMichael Orlitzky <mjo@gentoo.org>2019-06-25 10:28:53 -0400
commit5372dc2164679ced7d53b2918059f1dfc76b5ea8 (patch)
treea13c9cec9531bafde15c23578aed49f2eca0c565 /net-mail/fdm
parentwww-client/opera-developer: Old (diff)
downloadgentoo-5372dc2164679ced7d53b2918059f1dfc76b5ea8.tar.gz
gentoo-5372dc2164679ced7d53b2918059f1dfc76b5ea8.tar.bz2
gentoo-5372dc2164679ced7d53b2918059f1dfc76b5ea8.zip
net-mail/fdm: new version 2.0.
This new version is intended to fix bug 677484 that is killing the build. The previous version is a few years old, and an upgrade is probably easier than patching. The new version also has some other improvements: * Courier support was dropped (upstream commit bc34a567). * The ./configure script now supports --enable-pcre instead of passing PCRE=1 to "make". * The build system installs stuff into the correct locations without us passing variables to "make install". * User creation has been moved to pkg_preinst() since the user is only needed at runtime. * Use EAPI=7. * Drop unused eutils, multilib, and toolchain-funcs eclasses. Bug: https://bugs.gentoo.org/677484 Signed-off-by: Michael Orlitzky <mjo@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'net-mail/fdm')
-rw-r--r--net-mail/fdm/Manifest1
-rw-r--r--net-mail/fdm/fdm-2.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/net-mail/fdm/Manifest b/net-mail/fdm/Manifest
index fcf3fa2af8a0..1efb740bd86b 100644
--- a/net-mail/fdm/Manifest
+++ b/net-mail/fdm/Manifest
@@ -1 +1,2 @@
DIST fdm-1.9.tar.gz 299916 BLAKE2B 0c9bb9514a4d36fb1168be73fe745aa136cea75e0ebde28ab181be7d4b7e093c0bec775222e8a333e14baa90871739fa095a89bf8d1f16a86dee03b6d01021aa SHA512 e7e5c8aae8be3e82ff6015d2d87fd9d0dad4fe24796b4f30d6874f761e2df6900c8940d39de28bb2db6ee3ea3faf494c57149037657d986a3b54db3a6a601ca7
+DIST fdm-2.0.tar.gz 313596 BLAKE2B 8b323f4a8953a46773a4e5a1214444dc97db4346f50990fcfb4c9d79ae40bbb73b61e3bf41bc95b76e44f6bed7b398cb210d58901823752e92ca7b83189cbc7e SHA512 14e923202d17083ceb3b91b3a442d7e512c37f3d29535f22d8c0c4e1d57c97acc5d5465d643ed0cf437b3945ef777a6e38da3117219c2d54dcec88ecab1e10d9
diff --git a/net-mail/fdm/fdm-2.0.ebuild b/net-mail/fdm/fdm-2.0.ebuild
new file mode 100644
index 000000000000..72b297c3ac2f
--- /dev/null
+++ b/net-mail/fdm/fdm-2.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit user
+
+DESCRIPTION="fetch, filter and deliver mail"
+HOMEPAGE="https://github.com/nicm/fdm"
+SRC_URI="https://github.com/nicm/fdm/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples libressl pcre"
+
+DEPEND="!libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ sys-libs/tdb
+ pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGES README TODO MANUAL )
+
+src_configure() {
+ econf $(use_enable pcre)
+}
+
+src_install() {
+ default
+
+ if use examples ; then
+ docinto examples
+ dodoc examples/*
+ fi
+}
+
+pkg_preinst() {
+ # This user is hard-coded in fdm.h. If fdm is started as root,
+ # it will attempt to drop privileges (to this user).
+ enewuser _fdm
+}