summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/offlineimap/offlineimap-6.5.6.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/offlineimap/offlineimap-6.5.6.ebuild')
-rw-r--r--net-mail/offlineimap/offlineimap-6.5.6.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/net-mail/offlineimap/offlineimap-6.5.6.ebuild b/net-mail/offlineimap/offlineimap-6.5.6.ebuild
new file mode 100644
index 000000000000..897aab292024
--- /dev/null
+++ b/net-mail/offlineimap/offlineimap-6.5.6.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# Normally you need only one version of this.
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads,sqlite?,ssl?"
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Powerful IMAP/Maildir synchronization and reader support"
+HOMEPAGE="http://offlineimap.org"
+SRC_URI="https://github.com/OfflineIMAP/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ia64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc ssl sqlite"
+
+RDEPEND=""
+DEPEND="doc? ( dev-python/docutils )"
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}-* "${S}/"
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+ # see http://pogma.com/2009/09/09/snow-leopard-and-offlineimap/ and bug 284925
+ epatch "${FILESDIR}"/"${PN}-6.5.3.1"-darwin10.patch
+}
+
+src_compile() {
+ distutils-r1_src_compile
+ if use doc ; then
+ cd docs
+ rst2man.py MANUAL.rst offlineimap.1 || die "building manpage failed"
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc offlineimap.conf offlineimap.conf.minimal
+ if use doc ; then
+ cd docs
+ doman offlineimap.1 || die "installing manpage failed"
+ fi
+}
+
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-6.4" ; then
+ elog "If you upgraded from 6.3.* then you may need to update your config:"
+ elog ""
+ elog "If you use nametrans= settings on a remote repository, you will have"
+ elog "to add a \"reverse\" nametrans setting to the local repository, so that"
+ elog "it knows which folders it should (not) create on the remote side."
+ elog ""
+ fi
+}
+
+pkg_postinst() {
+ elog ""
+ elog "You will need to configure offlineimap by creating ~/.offlineimaprc"
+ elog "Sample configurations are in /usr/share/doc/${PF}/"
+ elog ""
+ elog "If you connect via ssl/tls and don't use CA cert checking, it will"
+ elog "display the server's cert fingerprint and require you to add it to the"
+ elog "configuration file to be sure it connects to the same server every"
+ elog "time. This serves to help fixing CVE-2010-4532 (offlineimap doesn't"
+ elog "check SSL server certificate) in cases where you have no CA cert."
+ elog ""
+
+ if use sqlite ; then
+ elog "The sqlite USE flag only enables a dependency on sqlite. To use"
+ elog "the sqlite backend you need to enable it in your .offlineimaprc"
+ fi
+}