summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/pfqueue
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/pfqueue')
-rw-r--r--net-mail/pfqueue/Manifest1
-rw-r--r--net-mail/pfqueue/files/pfqueue-0.5.6-tinfo.patch10
-rw-r--r--net-mail/pfqueue/metadata.xml11
-rw-r--r--net-mail/pfqueue/pfqueue-0.5.6.ebuild35
4 files changed, 57 insertions, 0 deletions
diff --git a/net-mail/pfqueue/Manifest b/net-mail/pfqueue/Manifest
new file mode 100644
index 000000000000..17bab985e302
--- /dev/null
+++ b/net-mail/pfqueue/Manifest
@@ -0,0 +1 @@
+DIST pfqueue-0.5.6.tar.gz 298870 SHA256 efedc8ea73ea09cf3edfbdbb6bf3fb0678017818fd0c1816abd9360120c59a41 SHA512 1bb622bba6d72ff98ee862d794854debcebabeff24cb6f06cecb06513f453cbb09f0cb8e5fa4c26bfde03aadbc5e803692279427021ccda10749a6c5a326bfb9 WHIRLPOOL f086055e1a26fdb524206f122d283bbfa8813e640f0800ab583748e6dbe86706798832ce25932b9424b38e4e3436e4e011bd0d9b23b9f9fd0c7ca2f0acbc9f2c
diff --git a/net-mail/pfqueue/files/pfqueue-0.5.6-tinfo.patch b/net-mail/pfqueue/files/pfqueue-0.5.6-tinfo.patch
new file mode 100644
index 000000000000..6efd5bb0d74b
--- /dev/null
+++ b/net-mail/pfqueue/files/pfqueue-0.5.6-tinfo.patch
@@ -0,0 +1,10 @@
+--- a/configure.in
++++ b/configure.in
+@@ -38,6 +38,7 @@
+
+ dnl Checks for library functions.
+ AC_CHECK_LIB(ncurses,newwin)
++AC_SEARCH_LIBS(COLS, tinfo)
+ AC_CHECK_LIB(pthread,pthread_create)
+ AC_CHECK_LIB(c_r,pthread_create)
+ AC_CHECK_LIB(dl,dlopen)
diff --git a/net-mail/pfqueue/metadata.xml b/net-mail/pfqueue/metadata.xml
new file mode 100644
index 000000000000..95b737b450fb
--- /dev/null
+++ b/net-mail/pfqueue/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <longdescription lang="en">
+ A ncurses-based tool for handling postfix queues.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">pfqueue</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-mail/pfqueue/pfqueue-0.5.6.ebuild b/net-mail/pfqueue/pfqueue-0.5.6.ebuild
new file mode 100644
index 000000000000..e778f6f02c49
--- /dev/null
+++ b/net-mail/pfqueue/pfqueue-0.5.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="pfqueue is an ncurses console-based tool for managing Postfix queued messages"
+HOMEPAGE="http://pfqueue.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND="
+ sys-libs/ncurses
+ sys-devel/libtool
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+DOCS=( README ChangeLog NEWS TODO AUTHORS )
+
+src_install() {
+ default
+ prune_libtool_files
+}