summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/poppassd_ceti
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/poppassd_ceti')
-rw-r--r--net-mail/poppassd_ceti/Manifest1
-rw-r--r--net-mail/poppassd_ceti/files/poppassd.xinetd12
-rw-r--r--net-mail/poppassd_ceti/metadata.xml14
-rw-r--r--net-mail/poppassd_ceti/poppassd_ceti-1.8.5-r1.ebuild46
-rw-r--r--net-mail/poppassd_ceti/poppassd_ceti-1.8.5-r2.ebuild41
5 files changed, 114 insertions, 0 deletions
diff --git a/net-mail/poppassd_ceti/Manifest b/net-mail/poppassd_ceti/Manifest
new file mode 100644
index 000000000000..32217afedd89
--- /dev/null
+++ b/net-mail/poppassd_ceti/Manifest
@@ -0,0 +1 @@
+DIST poppassd-1.8.5.tar.gz 6054 RMD160 03d181619adb0ccdfcc463bad75117700cb1d09a SHA1 0f5a59962de544bb875cedf0f8a114df86a98cd1 SHA256 3b4ccb61c9b97fd91add8b798429c7e1aee0561a19781e413186e9da733c95a8
diff --git a/net-mail/poppassd_ceti/files/poppassd.xinetd b/net-mail/poppassd_ceti/files/poppassd.xinetd
new file mode 100644
index 000000000000..7f0344781bce
--- /dev/null
+++ b/net-mail/poppassd_ceti/files/poppassd.xinetd
@@ -0,0 +1,12 @@
+service poppassd
+{
+ socket_type = stream
+ protocol = tcp
+ wait = no
+ user = root
+ server = /usr/sbin/poppassd
+ log_on_success += HOST DURATION
+ log_on_failure += HOST
+ disable = yes
+}
+
diff --git a/net-mail/poppassd_ceti/metadata.xml b/net-mail/poppassd_ceti/metadata.xml
new file mode 100644
index 000000000000..0ca7470eda81
--- /dev/null
+++ b/net-mail/poppassd_ceti/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <longdescription>
+ Provides a daemon for changing passwords over the network. This feature
+ is commonly used for TCP loopback password changing from web scripting
+ languages such as Perl and PHP, removing the requirement for setuid perl
+ scipts or running a web server process as root. This version of poppassd
+ has PAM support, and also optional support for cracklib enforcing the use
+ of strong passwords. Note that the protocol is plain text and so insecure
+ for all but loopback use.
+ </longdescription>
+</pkgmetadata>
diff --git a/net-mail/poppassd_ceti/poppassd_ceti-1.8.5-r1.ebuild b/net-mail/poppassd_ceti/poppassd_ceti-1.8.5-r1.ebuild
new file mode 100644
index 000000000000..108595331588
--- /dev/null
+++ b/net-mail/poppassd_ceti/poppassd_ceti-1.8.5-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs pam portability
+
+MY_PN="poppassd"
+MY_P="${MY_PN}-${PV}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Password change daemon with PAM support"
+HOMEPAGE="http://echelon.pl/pubs/poppassd.html"
+SRC_URI="http://echelon.pl/pubs/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="cracklib"
+
+DEPEND="virtual/pam"
+
+RDEPEND="${DEPEND}
+ sys-apps/xinetd
+ cracklib? ( sys-libs/cracklib )"
+
+src_compile() {
+ $(tc-getCC) -c ${CFLAGS} ${MY_PN}.c || die "Compile failed."
+ $(tc-getCC) -o poppassd ${MY_PN}.o -lpam $(dlopen_lib) || die "Linking failed."
+}
+
+src_install() {
+ dodoc README
+
+ pamd_mimic_system poppassd auth account password
+ if use cracklib; then
+ echo -e "password\trequired\tpam_cracklib.so retry=3" >> \
+ ${D}/etc/pam.d/poppassd
+ fi
+
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/poppassd.xinetd poppassd
+
+ insinto /usr/sbin
+ insopts -o root -g bin -m 500
+ doins poppassd || die "Install failed."
+}
diff --git a/net-mail/poppassd_ceti/poppassd_ceti-1.8.5-r2.ebuild b/net-mail/poppassd_ceti/poppassd_ceti-1.8.5-r2.ebuild
new file mode 100644
index 000000000000..a334d4446e37
--- /dev/null
+++ b/net-mail/poppassd_ceti/poppassd_ceti-1.8.5-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs pam portability
+
+MY_PN="poppassd"
+MY_P="${MY_PN}-${PV}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Password change daemon with PAM support"
+HOMEPAGE="http://echelon.pl/pubs/poppassd.html"
+SRC_URI="http://echelon.pl/pubs/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="virtual/pam"
+
+RDEPEND="${DEPEND}
+ sys-apps/xinetd"
+
+src_compile() {
+ $(tc-getCC) -c ${CFLAGS} ${MY_PN}.c || die "Compile failed."
+ $(tc-getCC) ${LDFLAGS} -o poppassd ${MY_PN}.o -lpam $(dlopen_lib) || die "Linking failed."
+}
+
+src_install() {
+ dodoc README
+
+ pamd_mimic_system poppassd auth account password
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/poppassd.xinetd poppassd
+
+ insinto /usr/sbin
+ insopts -o root -g bin -m 500
+ doins poppassd || die "Install failed."
+}