summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/qmailanalog/qmailanalog-0.70-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/qmailanalog/qmailanalog-0.70-r1.ebuild')
-rw-r--r--net-mail/qmailanalog/qmailanalog-0.70-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-mail/qmailanalog/qmailanalog-0.70-r1.ebuild b/net-mail/qmailanalog/qmailanalog-0.70-r1.ebuild
new file mode 100644
index 000000000000..6407b2c03964
--- /dev/null
+++ b/net-mail/qmailanalog/qmailanalog-0.70-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils fixheadtails toolchain-funcs
+
+DESCRIPTION="collection of tools to help you analyze qmail's activity record"
+SRC_URI="http://cr.yp.to/software/${P}.tar.gz"
+HOMEPAGE="http://cr.yp.to/qmailanalog.html"
+
+LICENSE="freedist public-domain" # public-domain for files/tai64nfrac.c
+SLOT="0"
+KEYWORDS="x86 sparc ~amd64"
+IUSE=""
+
+DEPEND="sys-apps/groff"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-errno.patch
+ ht_fix_file auto_home.c.do default.do Makefile
+}
+
+src_compile() {
+ echo "/var/qmail" > conf-home
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+
+ emake || die
+ $(tc-getCC) ${CFLAGS} "${FILESDIR}"/tai64nfrac.c -o tai64nfrac || die
+}
+
+src_test() { :; }
+
+src_install() {
+ doman matchup.1 xqp.1 xsender.1 xrecipient.1 columnt.1
+ dodoc MATCHUP ACCOUNTING BLURB
+
+ insopts -o root -g qmail -m 755
+ insinto /var/qmail/bin
+ into /var/qmail
+ dobin columnt ddist deferrals failures matchup recipients rhosts
+ dobin rxdelay senders successes suids xqp xrecipient xsender
+ dobin zddist zdeferrals zfailures zoverall zrecipients zrhosts
+ dobin zrxdelay zsenders zsendmail zsuccesses zsuids tai64nfrac
+}