summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/qpopper/qpopper-4.1.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/qpopper/qpopper-4.1.0.ebuild')
-rw-r--r--net-mail/qpopper/qpopper-4.1.0.ebuild124
1 files changed, 124 insertions, 0 deletions
diff --git a/net-mail/qpopper/qpopper-4.1.0.ebuild b/net-mail/qpopper/qpopper-4.1.0.ebuild
new file mode 100644
index 000000000000..3905e974e1c8
--- /dev/null
+++ b/net-mail/qpopper/qpopper-4.1.0.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+#inherit eutils flag-o-matic ssl-cert
+inherit eutils ssl-cert user
+
+MY_P=${PN}${PV}
+
+DESCRIPTION="A POP3 Server"
+HOMEPAGE="http://www.eudora.com/products/unsupported/qpopper/index.html"
+SRC_URI="ftp://ftp.qualcomm.com/eudora/servers/unix/popper/${MY_P}.tar.gz"
+
+LICENSE="qpopper ISOC-rfc"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug drac gdbm mailbox pam ssl xinetd apop"
+
+DEPEND="virtual/mta
+ >=net-mail/mailbase-0.00-r8
+ xinetd? ( virtual/inetd )
+ gdbm? ( sys-libs/gdbm )
+ drac? ( mail-client/drac )
+ pam? ( >=sys-libs/pam-0.72 )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ use apop && enewuser pop
+}
+
+src_prepare() {
+ # Test dirs are full of binary craft. Drop it.
+ rm -rf ./mmangle/test || die
+ epatch "${FILESDIR}"/${PN}-4.1-parallel-build.patch
+ sed -i -e 's:-o popauth:& ${LDFLAGS}:' popper/Makefile.in || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable !xinetd standalone) \
+ $(use_enable debug debugging) \
+ $(use_with ssl openssl) \
+ $(use_with gdbm) \
+ $(use_with pam pam pop3) \
+ $(use_enable apop apop /etc/pop.auth) \
+ $(use_enable mailbox home-dir-mail Mailbox) \
+ $(use_with drac) \
+ --enable-shy \
+ --enable-popuid=pop \
+ --enable-log-login \
+ --enable-specialauth \
+ --enable-spool-dir=/var/spool/mail \
+ --enable-log-facility=LOG_MAIL
+
+ if ! use gdbm; then
+ sed -i -e 's|#define HAVE_GDBM_H|//#define HAVE_GDBM_H|g' config.h || die "sed failed"
+ fi
+}
+
+src_install() {
+ if use apop; then
+ dosbin popper/popauth
+ fowners pop:root /usr/sbin/popauth
+ fperms 4110 /usr/sbin/popauth
+ doman man/popauth.8
+ fi
+
+ dosbin popper/popper
+ doman man/popper.8
+
+ insinto /etc
+ doins "${FILESDIR}/qpopper.conf"
+
+ if use ssl; then
+ sed -i -e 's:^# \(set tls-server-cert-file\).*:\1 = /etc/mail/certs/cert.pem:' \
+ -e 's:^# \(set tls-support\).*$:\1 = stls:'\
+ "${D}/etc/qpopper.conf"
+ fi
+
+ if use xinetd; then
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}/qpopper.xinetd" pop-3
+ else
+ newinitd "${FILESDIR}/qpopper.init.d" qpopper
+ fi
+
+ dodoc README doc/{Release.Notes,Changes}
+
+ docinto rfc
+ dodoc doc/rfc*.txt
+ dohtml doc/LMOS-FAQ.html
+
+ insinto /usr/share/doc/${PF}
+ doins GUIDE.pdf
+}
+
+pkg_postinst () {
+ if use ssl; then
+ install_cert /etc/mail/certs/cert
+ chown root:mail /etc/mail/certs
+ chmod 660 /etc/mail/certs
+ fi
+ if use apop; then
+ elog "To authenticate the users with APOP "
+ elog "you have to follow these steps:"
+ elog ""
+ elog "1) initialize the authentication database:"
+ elog " # popauth -init"
+ elog "2) new users can be added by root:"
+ elog " # popauth -user <user>"
+ elog " or removed:"
+ elog " # popauth -delete <user>"
+ elog " Other users can add themeselves or change their"
+ elog " password with the command popauth"
+ elog "3) scripts or other non-interactive processes can add or change"
+ elog " the passwords with the following command:"
+ elog " # popauth -user <user> <password>"
+ elog ""
+ fi
+}