summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/qtools/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/qtools/files')
-rw-r--r--net-mail/qtools/files/qtools-0.56-errno.patch12
-rw-r--r--net-mail/qtools/files/qtools-0.56-head.patch76
2 files changed, 88 insertions, 0 deletions
diff --git a/net-mail/qtools/files/qtools-0.56-errno.patch b/net-mail/qtools/files/qtools-0.56-errno.patch
new file mode 100644
index 000000000000..a5fdab64b733
--- /dev/null
+++ b/net-mail/qtools/files/qtools-0.56-errno.patch
@@ -0,0 +1,12 @@
+--- qtools-0.56.old/error.h 2000-03-18 14:01:20.000000000 -0800
++++ qtools-0.56/error.h 2003-03-23 21:50:05.000000000 -0800
+@@ -1,7 +1,8 @@
+ #ifndef ERROR_H
+ #define ERROR_H
+
+-extern int errno;
++/* extern int errno; */
++#include <errno.h>
+
+ extern int error_intr;
+ extern int error_nomem;
diff --git a/net-mail/qtools/files/qtools-0.56-head.patch b/net-mail/qtools/files/qtools-0.56-head.patch
new file mode 100644
index 000000000000..5032a7791c9d
--- /dev/null
+++ b/net-mail/qtools/files/qtools-0.56-head.patch
@@ -0,0 +1,76 @@
+diff -ur qtools-0.56/Makefile ../../qtools-0.56.patched/Makefile
+--- qtools-0.56/Makefile 2001-11-08 14:07:57.000000000 +0100
++++ ../../qtools-0.56.patched/Makefile 2005-06-29 00:44:05.000000000 +0200
+@@ -13,7 +13,7 @@
+ load: warn-auto.sh conf-ld
+ ( cat warn-auto.sh; \
+ echo 'main="$$1"; shift'; \
+- echo exec "`head -1 conf-ld`" \
++ echo exec "`head -n 1 conf-ld`" \
+ '-o "$$main" "$$main".o $${1+"$$@"}' \
+ ) > load
+ chmod 755 load
+@@ -27,7 +27,7 @@
+
+ compile: warn-auto.sh conf-cc
+ ( cat warn-auto.sh; \
+- echo exec "`head -1 conf-cc`" '-c $${1+"$$@"}' \
++ echo exec "`head -n 1 conf-cc`" '-c $${1+"$$@"}' \
+ ) > compile
+ chmod 755 compile
+
+@@ -57,8 +57,8 @@
+
+ systype: find-systype.sh conf-cc conf-ld trycpp.c x86cpuid.c
+ ( cat warn-auto.sh; \
+- echo CC=\'`head -1 conf-cc`\'; \
+- echo LD=\'`head -1 conf-ld`\'; \
++ echo CC=\'`head -n 1 conf-cc`\'; \
++ echo LD=\'`head -n 1 conf-ld`\'; \
+ cat find-systype.sh; \
+ ) | sh > systype
+
+@@ -379,7 +379,7 @@
+
+ choose: warn-auto.sh choose.sh conf-home
+ cat warn-auto.sh choose.sh \
+- | sed s}HOME}"`head -1 conf-home`"}g \
++ | sed s}HOME}"`head -n 1 conf-home`"}g \
+ > choose
+ chmod 755 choose
+
+@@ -529,7 +529,7 @@
+ ./compile checkdomain.c
+
+ auto_qmail.c: auto-str conf-qmail
+- ./auto-str auto_qmail `head -1 conf-qmail` > auto_qmail.c
++ ./auto-str auto_qmail `head -n 1 conf-qmail` > auto_qmail.c
+
+ filterto.o: compile \
+ filterto.c \
+@@ -660,7 +660,7 @@
+
+ rts: warn-auto.sh rts.sh conf-home
+ cat warn-auto.sh rts.sh \
+- | sed s}HOME}"`head -1 conf-home`"}g \
++ | sed s}HOME}"`head -n 1 conf-home`"}g \
+ > rts
+ chmod 755 rts
+
+@@ -715,14 +715,14 @@
+ ./compile auto_ezmlm.c
+
+ auto_ezmlm.c: auto-str conf-ezmlm
+- ./auto-str auto_ezmlm `head -1 conf-ezmlm` > auto_ezmlm.c
++ ./auto-str auto_ezmlm `head -n 1 conf-ezmlm` > auto_ezmlm.c
+
+ auto_home.o: compile \
+ auto_home.c
+ ./compile auto_home.c
+
+ auto_home.c: auto-str conf-home
+- ./auto-str auto_home `head -1 conf-home` > auto_home.c
++ ./auto-str auto_home `head -n 1 conf-home` > auto_home.c
+
+ install: load install.o hier.o auto_home.o stralloc.a alloc.a strerr.a \
+ buffer.a open.a error.a str.a