summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/queue-fix
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/queue-fix')
-rw-r--r--net-mail/queue-fix/Manifest2
-rw-r--r--net-mail/queue-fix/metadata.xml14
-rw-r--r--net-mail/queue-fix/queue-fix-1.4-r2.ebuild37
3 files changed, 53 insertions, 0 deletions
diff --git a/net-mail/queue-fix/Manifest b/net-mail/queue-fix/Manifest
new file mode 100644
index 000000000000..762822a52c16
--- /dev/null
+++ b/net-mail/queue-fix/Manifest
@@ -0,0 +1,2 @@
+DIST queue-fix-1.4.tar.gz 18486 SHA256 63da6360e3225a8fef38925b53a18e67a1197eea1f42fd41bbc928f20a0d0496 SHA512 b7e0ac070a409eff156b3803cc1bb78d1c800ae685d107b872bf5b022a8645d1ca55a5c3380f6bc82e99927df8dbf586b74af587e882938b9a7678b506c600e0 WHIRLPOOL 07755cc53ebf23c774333b2aab7d09d06653b2ea40faf94e4c9cd36cd57a78cc69bbd153b5120475b242913108a2f51805abd8cf7ccbdf5fb921dd425a02991c
+DIST queue-fix-todo.patch 3056 SHA256 911f84081d0fb68878a0744f5859ce7a45792606cd0af31945cccb41f0d01a7f SHA512 78d79f1eaa8492fd9a14dc4a4d2adfaa8c0429a4faec32305f83ea1f16769b8d337fe732adc8cc0c33b909a19617862c9df999f2e938a6b845e15bc49ab5bfbe WHIRLPOOL fc03a9923b57372db5c34a3dd8415cb6131ccdc267b2f07213a5f45ebb99bc474e904289438fe8ab86e5ab695e225c1905c665d20d17c5052e413cfe16c934fd
diff --git a/net-mail/queue-fix/metadata.xml b/net-mail/queue-fix/metadata.xml
new file mode 100644
index 000000000000..a20f1429ccc3
--- /dev/null
+++ b/net-mail/queue-fix/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qmail</herd>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ <description>Primary Maintainer</description>
+</maintainer>
+<longdescription>It repairs or generates a qmail queue structure. You can use
+ this to help move your queue location, or if you regenerate the file system
+ and the inode numbering changes. It will also fix permissions and
+ ownerships of the files.</longdescription>
+</pkgmetadata>
diff --git a/net-mail/queue-fix/queue-fix-1.4-r2.ebuild b/net-mail/queue-fix/queue-fix-1.4-r2.ebuild
new file mode 100644
index 000000000000..645233562b4b
--- /dev/null
+++ b/net-mail/queue-fix/queue-fix-1.4-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs fixheadtails
+
+DESCRIPTION="Qmail Queue Repair Application with support for big-todo"
+HOMEPAGE="http://www.netmeridian.com/e-huss/"
+SRC_URI="http://www.netmeridian.com/e-huss/${P}.tar.gz
+ mirror://qmail/queue-fix-todo.patch"
+
+LICENSE="all-rights-reserved public-domain" # includes code from qmail
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc s390 sh sparc x86"
+RESTRICT="mirror bindist"
+
+PDEPEND="virtual/qmail"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ epatch "${DISTDIR}"/queue-fix-todo.patch
+ sed -i 's/^extern int errno;/#include <errno.h>/' "${S}"/error.h
+ ht_fix_file "${S}"/Makefile*
+}
+
+src_compile() {
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ emake || die
+}
+
+src_install () {
+ into /var/qmail
+ dobin queue-fix || die
+ into /usr
+ dodoc README CHANGES
+}