summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-04-20 09:28:05 +0200
committerSebastian Pipping <sping@gentoo.org>2020-04-20 09:28:51 +0200
commit438a93f63081fefb328daffc127d98e078a7e467 (patch)
treef941a4e09b1f8b4ab644077c1b6adbd8e74b7622 /net-mail/rss2email
parentdev-cpp/abseil-cpp: whitespace (diff)
downloadgentoo-438a93f63081fefb328daffc127d98e078a7e467.tar.gz
gentoo-438a93f63081fefb328daffc127d98e078a7e467.tar.bz2
gentoo-438a93f63081fefb328daffc127d98e078a7e467.zip
net-mail/rss2email: py3[78] + QA
Closes: https://bugs.gentoo.org/718436 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.99, Repoman-2.3.22
Diffstat (limited to 'net-mail/rss2email')
-rw-r--r--net-mail/rss2email/rss2email-3.11-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-mail/rss2email/rss2email-3.11-r1.ebuild b/net-mail/rss2email/rss2email-3.11-r1.ebuild
new file mode 100644
index 000000000000..2459d85da411
--- /dev/null
+++ b/net-mail/rss2email/rss2email-3.11-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python script that converts RSS/Atom newsfeeds to email"
+HOMEPAGE="https://github.com/rss2email/rss2email"
+SRC_URI="https://github.com/rss2email/rss2email/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/feedparser-5.0.1[${PYTHON_USEDEP}]
+ >=dev-python/html2text-3.01[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ distutils-r1_src_install
+ doman r2e.1
+}