summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/vchkuser
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/vchkuser')
-rw-r--r--net-mail/vchkuser/Manifest2
-rw-r--r--net-mail/vchkuser/metadata.xml11
-rw-r--r--net-mail/vchkuser/vchkuser-0.3.3.ebuild39
-rw-r--r--net-mail/vchkuser/vchkuser-0.4.ebuild41
4 files changed, 93 insertions, 0 deletions
diff --git a/net-mail/vchkuser/Manifest b/net-mail/vchkuser/Manifest
new file mode 100644
index 000000000000..67c99af56c79
--- /dev/null
+++ b/net-mail/vchkuser/Manifest
@@ -0,0 +1,2 @@
+DIST vchkuser-0.3.3.tar.bz2 6057 SHA256 a104a5ca6fc091a0d255d3eac20b4670f28b75285323fdf27fc98bdd6d53cadf
+DIST vchkuser-0.4.tar.gz 5890 SHA256 314cf937e24b6460ca816fde0d25119054ef880373151082e913aeccf9f92edd
diff --git a/net-mail/vchkuser/metadata.xml b/net-mail/vchkuser/metadata.xml
new file mode 100644
index 000000000000..5837c64ada49
--- /dev/null
+++ b/net-mail/vchkuser/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qmail</herd>
+ <use>
+ <flag name="debug">Enables debug messages to syslog</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">hollow/vchkuser</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-mail/vchkuser/vchkuser-0.3.3.ebuild b/net-mail/vchkuser/vchkuser-0.3.3.ebuild
new file mode 100644
index 000000000000..70469c0839a6
--- /dev/null
+++ b/net-mail/vchkuser/vchkuser-0.3.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit autotools qmail
+
+DESCRIPTION="qmail-spp plugin to check recipient existance with vpopmail"
+HOMEPAGE="http://github.com/hollow/vchkuser"
+SRC_URI="http://bb.xnull.de/projects/vchkuser/dist/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="net-mail/vpopmail
+ || ( mail-mta/netqmail[qmail-spp] mail-mta/qmail-ldap[qmail-spp] )"
+RDEPEND=""
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ --with-vpopuser=vpopmail \
+ --with-qmailgroup=nofiles \
+ --with-vpopmaildir=/var/vpopmail \
+ --with-qmaildir=${QMAIL_HOME}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake failed"
+ fowners vpopmail:nofiles "${QMAIL_HOME}"/plugins/vchkuser
+ fperms 4750 "${QMAIL_HOME}"/plugins/vchkuser
+}
diff --git a/net-mail/vchkuser/vchkuser-0.4.ebuild b/net-mail/vchkuser/vchkuser-0.4.ebuild
new file mode 100644
index 000000000000..8e20c1809460
--- /dev/null
+++ b/net-mail/vchkuser/vchkuser-0.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit autotools qmail
+
+DESCRIPTION="qmail-spp plugin to check recipient existance with vpopmail"
+HOMEPAGE="http://github.com/hollow/vchkuser"
+SRC_URI="http://github.com/hollow/vchkuser/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+DEPEND="net-mail/vpopmail
+ || ( mail-mta/netqmail[qmail-spp] mail-mta/qmail-ldap[qmail-spp] )"
+RDEPEND=""
+
+S="${WORKDIR}/hollow-${PN}-8a048f7"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ --with-vpopuser=vpopmail \
+ --with-qmailgroup=nofiles \
+ --with-vpopmaildir=/var/vpopmail \
+ --with-qmaildir=${QMAIL_HOME}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake failed"
+ fowners vpopmail:nofiles "${QMAIL_HOME}"/plugins/vchkuser
+ fperms 4750 "${QMAIL_HOME}"/plugins/vchkuser
+}