summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2020-04-01 10:57:01 +0200
committerHanno Böck <hanno@gentoo.org>2020-04-01 10:57:01 +0200
commit366e02e26c41c6ba19a384c0f904c912d64500c8 (patch)
tree59978fd32587d4ced7d6764a96c5211740377e73 /net-mail
parentdev-cpp/tbb: version bump to 2020.2 (diff)
downloadgentoo-366e02e26c41c6ba19a384c0f904c912d64500c8.tar.gz
gentoo-366e02e26c41c6ba19a384c0f904c912d64500c8.tar.bz2
gentoo-366e02e26c41c6ba19a384c0f904c912d64500c8.zip
net-mail/mailman: Version bump.
Add patch to adress importlib_resources issue. Signed-off-by: Hanno Böck <hanno@gentoo.org> Package-Manager: Portage-2.3.96, Repoman-2.3.22
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mailman/Manifest2
-rw-r--r--net-mail/mailman/mailman-3.3.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/net-mail/mailman/Manifest b/net-mail/mailman/Manifest
index 9059e559f094..2a6cd486f349 100644
--- a/net-mail/mailman/Manifest
+++ b/net-mail/mailman/Manifest
@@ -1,3 +1,5 @@
DIST mailman-2.1.29.tgz 9376258 BLAKE2B 63ae740abed79d2887eef35ddfd8b51f22ee984a0eaacddeb34afb8147c0d239e5eaf93579face987b3c604653fed4c13233de78298914b4eacf5a33f769a997 SHA512 ed25179a4580092629890664c5502908b20e326c2ed06ad4e597fb4e8de84076c369ecd7a272be5ed8a1cb4479413d0e004d87804de763ee850e4d04d9a83376
DIST mailman-3.1.1.tar.gz 749014 BLAKE2B 00cf756de1a6ce5a05f30b033ad7d1ebc5664bb1c6fadb5d602c4e34e373ee7a0df0801e6b68b0816ee819f77caef33bbc4b8490df1c8f01fd2fb35664fd3757 SHA512 b09962ec99ca1ce1eafd40409a00f976dc47d82adb707313f4516400db6439af8597a1c4e30262fb228c102508ede688912480dbb1dcca9721bb0333693f1d85
DIST mailman-3.2.1.tar.gz 781654 BLAKE2B ee9a9bf5505ba638417c363a885153dbaa795213a77ca9dd5abb7212ac0fe35d08c5e0e87da2d54aeb50d21c30df72a750bd25ffa0877d377a3871bded03c7de SHA512 b17fa878ffe539504ce7f28351f5bf3c7aafe29fe98957880a571e5b798ad4f9f56748fb69df699b8bf9889aebb6cef075c5d075d653fa5e9b6feb0322eab9e6
+DIST mailman-3.3.0-importlib_resources-fix.diff.xz 2120 BLAKE2B d455a88a922fe715cb3e3faf6d7f94115ab0e762b85a3195988c9bcb0d01b37d4495e4c30c566f10f65f47c55f18c8af46e21037fca042503167238c88e1ff77 SHA512 31e6f71ff700a3e648b78b75808ac40b333ed58f3d51819b959f48ef4598f0e5d07d3b4fc178745702c02fb3137941c9887a6bd1cdd9ea7d18cd50d32da6c57f
+DIST mailman-3.3.0.tar.gz 839241 BLAKE2B a9f972a5cd09be6e971b568066cf67980c050fc619bc0bba7956d65b9601613f2dd87bbf243072be2478367e2fecfd48b184dada6fc525dae8cf1414dc64cec0 SHA512 63cf30c102751c1cae086f4c046767c2d817ad57097bd60bc838ead19c4e29ed1bc5d4cc2c1eef40f41787daf60d8b98033f64064d6ad4567a9552b5fb2cabd8
diff --git a/net-mail/mailman/mailman-3.3.0.ebuild b/net-mail/mailman/mailman-3.3.0.ebuild
new file mode 100644
index 000000000000..6edaba45f231
--- /dev/null
+++ b/net-mail/mailman/mailman-3.3.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Already prepared for python 3.7, but not all deps are ready,
+# see #691528
+PYTHON_COMPAT=( python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Mailman -- the GNU mailing list manager"
+HOMEPAGE="https://www.list.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ mirror://gentoo/${P}-importlib_resources-fix.diff.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+#KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="" # nothing til this is finished
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/aiosmtpd-1.1[${PYTHON_USEDEP}]
+ dev-python/alembic[${PYTHON_USEDEP}]
+ dev-python/atpublic[${PYTHON_USEDEP}]
+ >=dev-python/authheaders-0.13.0[${PYTHON_USEDEP}]
+ >=dev-python/authres-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/falcon-1.0.0[${PYTHON_USEDEP}]
+ dev-python/flufl-bounce[${PYTHON_USEDEP}]
+ >=dev-python/flufl-i18n-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/flufl-lock-3.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/importlib_resources[${PYTHON_USEDEP}]' python3_6)
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ dev-python/lazr-config[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.0[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.2.3[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-configuration[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+"
+
+# Make it compatible with python 3.7 and 3.6, see
+# https://gitlab.com/mailman/mailman/-/issues/690
+PATCHES=( "${WORKDIR}/mailman-3.3.0-importlib_resources-fix.diff" )