summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-28 16:17:07 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-28 16:17:07 +0100
commit6796db127fbf907abf5cf22f7a14954811cd3926 (patch)
tree8c1e621e3eaf5ae045fc34d662306aba03cce253 /net-mail
parentdev-libs/shhopt: Disable static-libs (diff)
downloadgentoo-6796db127fbf907abf5cf22f7a14954811cd3926.tar.gz
gentoo-6796db127fbf907abf5cf22f7a14954811cd3926.tar.bz2
gentoo-6796db127fbf907abf5cf22f7a14954811cd3926.zip
net-mail/eps: Port to EAPI 7
Closes: https://bugs.gentoo.org/727836 Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/eps/eps-1.7-r1.ebuild8
-rw-r--r--net-mail/eps/files/eps-1.7-static-libs.patch22
2 files changed, 25 insertions, 5 deletions
diff --git a/net-mail/eps/eps-1.7-r1.ebuild b/net-mail/eps/eps-1.7-r1.ebuild
index 92434d568c07..40d368deccd5 100644
--- a/net-mail/eps/eps-1.7-r1.ebuild
+++ b/net-mail/eps/eps-1.7-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit toolchain-funcs
@@ -12,10 +12,8 @@ SRC_URI="http://www.inter7.com/eps/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ppc x86"
-IUSE=""
-DEPEND="sys-apps/sed"
-RDEPEND=""
+PATCHES=( "${FILESDIR}"/${P}-static-libs.patch )
src_prepare() {
sed -i -e 's:/usr:$(DESTDIR)$(prefix):g' \
diff --git a/net-mail/eps/files/eps-1.7-static-libs.patch b/net-mail/eps/files/eps-1.7-static-libs.patch
new file mode 100644
index 000000000000..06fa8bc82559
--- /dev/null
+++ b/net-mail/eps/files/eps-1.7-static-libs.patch
@@ -0,0 +1,22 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ CC = gcc
+ AR = ar
+ STRIP = strip
+-LIB = libeps.a libeps.so
++LIB = libeps.so
+
+ AROPTS = -cru
+ RANLIB = ranlib
+@@ -20,10 +20,6 @@ DEFS = -Wall -I.
+
+ all: $(LIB)
+
+-libeps.a: $(OBJS)
+- $(AR) $(AROPTS) libeps.a $(OBJS)
+- $(RANLIB) libeps.a
+-
+ libeps.so: $(OBJS)
+ $(CC) -shared -o libeps.so $(OBJS)
+