summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2019-09-07 22:58:50 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-09-07 22:58:50 +0200
commit81e9c2ac67b548824bdd3c49d80feff6e03dcf40 (patch)
treeaa2f34d745fcec965e7c692c41b94ae5dc2c9920 /net-mail
parentapp-emacs/vhdl-mode: Remove old. (diff)
downloadgentoo-81e9c2ac67b548824bdd3c49d80feff6e03dcf40.tar.gz
gentoo-81e9c2ac67b548824bdd3c49d80feff6e03dcf40.tar.bz2
gentoo-81e9c2ac67b548824bdd3c49d80feff6e03dcf40.zip
net-mail/isync: Version bump, bug 689044
Closes: https://bugs.gentoo.org/689044 Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/isync/Manifest1
-rw-r--r--net-mail/isync/isync-1.3.1.ebuild44
-rw-r--r--net-mail/isync/isync-9999.ebuild6
3 files changed, 49 insertions, 2 deletions
diff --git a/net-mail/isync/Manifest b/net-mail/isync/Manifest
index b40b69a042ac..ca24db4d87f9 100644
--- a/net-mail/isync/Manifest
+++ b/net-mail/isync/Manifest
@@ -1 +1,2 @@
DIST isync-1.3.0.tar.gz 309459 BLAKE2B 852b37e1d9d5b0c4fc2f84305e88263adff5448ea355782da17f295a22e3265e68edcc049ce6172155ab0be7518a0431091d45f4e012f49b500fde7c28491ece SHA512 b5186f2afe97cab58ce55d3ec19ae7371676ae614448614a9e3e02d09662c34b74e559f0926661fa0300ab22dab9e2e9089b78ee38b94141ff3f8b4d75578ffa
+DIST isync-1.3.1.tar.gz 311868 BLAKE2B e7eae36407873b8f9f3c4e9a827e719aefa608994f5a48a93779207148123c7b796f6aa8ad8157f5eb9e863c5845889ad595d23570f12a0520fe997f8282158c SHA512 59d702d41d4a4e72f03cb282b414d0bb859593171763e845bc24d116a74f807a79e5be61f1dd1f59a9ece492322bceac156b08958a246cbfbe7f230fab4cdda2
diff --git a/net-mail/isync/isync-1.3.1.ebuild b/net-mail/isync/isync-1.3.1.ebuild
new file mode 100644
index 000000000000..a9663859bf83
--- /dev/null
+++ b/net-mail/isync/isync-1.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="MailDir mailbox synchronizer"
+HOMEPAGE="http://isync.sourceforge.net/"
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/${PN}/${PN}"
+ inherit git-r3 autotools
+else
+ SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc ~x86"
+fi
+
+IUSE="libressl sasl ssl zlib"
+
+RDEPEND="
+ >=sys-libs/db-4.2:=
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-0.9.6:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ zlib? ( sys-libs/zlib:0= )
+"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+"
+
+src_prepare () {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure () {
+ econf \
+ $(use_with ssl) \
+ $(use_with sasl) \
+ $(use_with zlib)
+}
diff --git a/net-mail/isync/isync-9999.ebuild b/net-mail/isync/isync-9999.ebuild
index a91ca12fb5bf..a9663859bf83 100644
--- a/net-mail/isync/isync-9999.ebuild
+++ b/net-mail/isync/isync-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -27,7 +27,9 @@ RDEPEND="
)
zlib? ( sys-libs/zlib:0= )
"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+"
src_prepare () {
default