summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-07-27 18:18:50 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-07-27 18:19:06 -0500
commitdbe00997921d45989109e352474d5a96f5e0b716 (patch)
tree5f4f523f0fb2f09df9f7755bdcab3f7414ad5801 /net-mail
parentdev-python/authheaders: add for mailman2 (diff)
downloadgentoo-dbe00997921d45989109e352474d5a96f5e0b716.tar.gz
gentoo-dbe00997921d45989109e352474d5a96f5e0b716.tar.bz2
gentoo-dbe00997921d45989109e352474d5a96f5e0b716.zip
net-mail/mailman: update to 3.2.1
Fixes: https://bugs.gentoo.org/548078 Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mailman/Manifest1
-rw-r--r--net-mail/mailman/mailman-3.2.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/net-mail/mailman/Manifest b/net-mail/mailman/Manifest
index 4be29fe09099..9059e559f094 100644
--- a/net-mail/mailman/Manifest
+++ b/net-mail/mailman/Manifest
@@ -1,2 +1,3 @@
DIST mailman-2.1.29.tgz 9376258 BLAKE2B 63ae740abed79d2887eef35ddfd8b51f22ee984a0eaacddeb34afb8147c0d239e5eaf93579face987b3c604653fed4c13233de78298914b4eacf5a33f769a997 SHA512 ed25179a4580092629890664c5502908b20e326c2ed06ad4e597fb4e8de84076c369ecd7a272be5ed8a1cb4479413d0e004d87804de763ee850e4d04d9a83376
DIST mailman-3.1.1.tar.gz 749014 BLAKE2B 00cf756de1a6ce5a05f30b033ad7d1ebc5664bb1c6fadb5d602c4e34e373ee7a0df0801e6b68b0816ee819f77caef33bbc4b8490df1c8f01fd2fb35664fd3757 SHA512 b09962ec99ca1ce1eafd40409a00f976dc47d82adb707313f4516400db6439af8597a1c4e30262fb228c102508ede688912480dbb1dcca9721bb0333693f1d85
+DIST mailman-3.2.1.tar.gz 781654 BLAKE2B ee9a9bf5505ba638417c363a885153dbaa795213a77ca9dd5abb7212ac0fe35d08c5e0e87da2d54aeb50d21c30df72a750bd25ffa0877d377a3871bded03c7de SHA512 b17fa878ffe539504ce7f28351f5bf3c7aafe29fe98957880a571e5b798ad4f9f56748fb69df699b8bf9889aebb6cef075c5d075d653fa5e9b6feb0322eab9e6
diff --git a/net-mail/mailman/mailman-3.2.1.ebuild b/net-mail/mailman/mailman-3.2.1.ebuild
new file mode 100644
index 000000000000..108bd97f853c
--- /dev/null
+++ b/net-mail/mailman/mailman-3.2.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Mailman -- the GNU mailing list manager"
+HOMEPAGE="http://www.list.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+#KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="" # nothing til this is finished
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/aiosmtpd-1.1[${PYTHON_USEDEP}]
+ dev-python/alembic[${PYTHON_USEDEP}]
+ dev-python/atpublic[${PYTHON_USEDEP}]
+ >=dev-python/authheaders-0.9.2[${PYTHON_USEDEP}]
+ >=dev-python/authres-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/falcon-1.0.0[${PYTHON_USEDEP}]
+ dev-python/flufl-bounce[${PYTHON_USEDEP}]
+ >=dev-python/flufl-i18n-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/flufl-lock-3.1[${PYTHON_USEDEP}]
+ dev-python/importlib_resources[${PYTHON_USEDEP}]
+ dev-python/lazr-config[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.0[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.2.3[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-configuration[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+"