summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2015-08-11 01:39:53 +0200
committerMichael Weber <xmw@gentoo.org>2015-08-11 01:40:43 +0200
commit9cced17d2a04989d6fede3141bcb90f3ea9b0914 (patch)
tree386b3a4135951e71de274683166167d24efe97c1 /net-misc/aiccu/aiccu-2007.01.15-r5.ebuild
parentmedia-sound/pnmixer: update live ebuild (diff)
downloadgentoo-9cced17d2a04989d6fede3141bcb90f3ea9b0914.tar.gz
gentoo-9cced17d2a04989d6fede3141bcb90f3ea9b0914.tar.bz2
gentoo-9cced17d2a04989d6fede3141bcb90f3ea9b0914.zip
net-misc/aiccu: fix for gnutls-3.4 and adjust dep (bug 549014, thanks spam and alpinelinux).
Package-Manager: portage-2.2.20
Diffstat (limited to 'net-misc/aiccu/aiccu-2007.01.15-r5.ebuild')
-rw-r--r--net-misc/aiccu/aiccu-2007.01.15-r5.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/net-misc/aiccu/aiccu-2007.01.15-r5.ebuild b/net-misc/aiccu/aiccu-2007.01.15-r5.ebuild
new file mode 100644
index 000000000000..a1c209bb7a74
--- /dev/null
+++ b/net-misc/aiccu/aiccu-2007.01.15-r5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils linux-info systemd toolchain-funcs
+
+DESCRIPTION="AICCU Client to configure an IPv6 tunnel to SixXS"
+HOMEPAGE="http://www.sixxs.net/tools/aiccu"
+SRC_URI="http://www.sixxs.net/archive/sixxs/aiccu/unix/${PN}_${PV//\./}.tar.gz"
+
+LICENSE="SixXS"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+IUSE="systemd"
+
+RDEPEND="
+ net-libs/gnutls
+ sys-apps/iproute2
+ systemd? ( sys-apps/systemd )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${PN}
+
+CONFIG_CHECK="~TUN"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-r2-init.gentoo.patch \
+ "${FILESDIR}"/${P}-Makefile.patch \
+ "${FILESDIR}"/${P}-setupscript.patch \
+ "${FILESDIR}"/${P}-uclibc.patch \
+ "${FILESDIR}"/${P}-systemd.patch \
+ "${FILESDIR}"/${P}-gnutls-3.4.patch
+}
+
+src_compile() {
+ # Don't use main Makefile since it requires additional
+ # dependencies which are useless for us.
+ emake CC=$(tc-getCC) STRIP= -C unix-console \
+ HAVE_SYSTEMD=$(usex systemd 1 0)
+}
+
+src_install() {
+ dosbin unix-console/${PN}
+
+ insopts -m 600
+ insinto /etc
+ doins doc/${PN}.conf
+ newinitd doc/${PN}.init.gentoo ${PN}
+
+ use systemd && systemd_dounit doc/${PN}.service
+
+ dodoc doc/{HOWTO,README,changelog}
+}